httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyle Owen" <Owen.Bo...@swx.com>
Subject RE: [users@httpd] Unable to use apachectl to start
Date Mon, 07 Aug 2006 13:59:59 GMT
> -----Original Message-----
> From: Gordon Low [mailto:glow2797@bigpond.net.au] 
> Sent: Monday, August 07, 2006 2:19 PM
> To: users@httpd.apache.org
> Subject: [users@httpd] Unable to use apachectl to start
> 
> 
> 
> Hoping that I can get some help with what may be a straight 
> forward problem
> to some of you.
> 
> Have a fairly simple home setup on a PC running Debian Sarge 
> with a Linux
> 2.4 kernel and noticed I couldn't access the website at the 
> home directory
> /home/~
> 
> Went to recompile Apache with --suexec-userdir which I 
> thought was missing.
> Haven't done this before (went easy from 2.0.3.. to 2.0.59) 
> and finally used
> ./configure to include what I thought I would need. At this 
> point I changed
> the name to apache2 as the installation which loaded with Debian was
> installed with apache2.conf, used apache2ctl etc.
> 
> To get to the point, I saved off the apache2.conf files and 
> done a 'make
> install'.
> 
> At this point I then tried to stop apache but couldn't as it 
> started looking
> for httpd and said it couldn't find the pid. Finally got 
> impatient and done
> a  'kill' on all the processes. Now find I can't start apache 
> and it says
> there is something using the port and that it can't write to 
> the logs. There
> are no httpd or apache2 processes running.
> 
> Hoping there is some way I can recover from this by manually clearing
> whatever apache seems to be getting blocked on. Had a problem 
> before where
> it couldn't find port 80 but fixed that by making sure it was 
> getting to the
> .conf file so have both apache2.conf and httpd.conf 
> configured the same now,
> still won't start.
> Have tried finding out what apachectl does so I can follow it 
> through but
> not having much luck.
> Can see the pid files in /var/run but don't know what to do here.

The simplest thing would be to reboot. That will clear any zombie
processes and get rid of stale filehandles. Then try to start apache
with your new setup.

BTW, I'm assuming you don't start apache on boot (ie, in /etc/rc3.d or
/etc/rc.local or whatever). 

It's always a nuisance to upgrade a vendor apache - it's usually best to
clear it out and make a fresh install in a canonical location (eg,
/usr/local/apache2).

Rgds,
Owen Boyle
Disclaimer: Any disclaimer attached to this message may be ignored. 
> 
> Help!!!!
> 
> Thanks
> 
> Gordon Low
> 
> 
> Thanks
> 
> Gordon Low
> 12 Kiriwina Place,
> Glenfield NSW 2167
> Mobile: 0409658319
> Home: (02)96181428
> email: glow2797@bigpond.net.au
> homepage: gordon.lowdown.id.au
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP 
> Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
 
 
This message is for the named person's use only. It may contain confidential, proprietary
or legally privileged information. No confidentiality or privilege is waived or lost by any
mistransmission. If you receive this message in error, please notify the sender urgently and
then immediately delete the message and any copies of it from your system. Please also immediately
destroy any hardcopies of the message. You must not, directly or indirectly, use, disclose,
distribute, print, or copy any part of this message if you are not the intended recipient.
The sender's company reserves the right to monitor all e-mail communications through their
networks. Any views expressed in this message are those of the individual sender, except where
the message states otherwise and the sender is authorised to state them to be the views of
the sender's company.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message