httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Buckley <Andy.Buck...@durham.ac.uk>
Subject Re: [users@httpd] SetOutputFilter doesn't work in <Location>s?
Date Mon, 07 Aug 2006 12:57:37 GMT
Andy Buckley wrote:
> Andy Buckley wrote:
>> Axel-St├ęphane SMORGRAV wrote:
>>>  
>>> SetOutputFilter works very well, even in Location filters. There are 
>>> lots of happy customers of this feature, using it for such things as 
>>> for example compression of response bodies.
> 
>> I tried with a configuration similar to yours and, yes, it works! The 
>> Header module is a new one for me: nice to know. A bit of 
>> investigation seems to reveal that adding another Location with a 
>> MultiViews DirectoryIndex can stop the filter from working:

[...]

> ... to get output filters working by Location I had to specify 
 > Options -MultiViews. I need to use MultiViews *and* output
 > filters, and this seems to be a bug that prevents simultaneous use.
> 
> Can someone confirm or deny this behaviour and recommend on whether it 
> should be reported to the Apache bug tracker? I've now observed it on 
> several copies of Apache 2.0.52 as bundled with different Linux systems, 

Hello again,

Any confirmations or denials before I post this as a bug report? I've also 
confirmed it with an Ubuntu Linux system running Apache 2.0.55.

Thanks,
Andy

-- 
Andy Buckley: CEDAR @ IPPP, Durham
Work: www.cedar.ac.uk
www.insectnation.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message