httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nima S Panahi <...@panahi.com>
Subject [users@httpd] Cache problems with apache2.0
Date Thu, 24 Aug 2006 19:49:40 GMT
Hi,
I have Mandrake Linux 2006 which uses apache 2.0.54. By default it  
uses the caching system, or so I think since it creates  
/var/cache/httpd and populates it.
I use apache primarily with postnuke and horde/imp with mysql as the db.
When I first installed the system in March, everything worked fine.  
Then about a month ago users started complaining about sometimes  
getting weird results, like getting logged out or not being able to  
log in or old messages showing up or  being send. These were rare,  
then about 2 days ago, everything went to hell. No one could use the  
system. Now nothing has changed, except the cachce files and the logs.  
I know becuase, I have a full system backup before the problems showed  
up and I compared the backed up files against the current files and  
except basically the apache cache files, misc temp files, mail files,  
and logs files, everything was identical. So nobody broke in nor were  
anyfiles curropted.
Things that happen include:
1. Not being able to log in. This happens with both postnuke and  
horde. People login and log files show they logged in successfully. In  
the case of horde/imp they even see the INBOX. But clicking on  
anything brings then back to the login page. Sometimes it shows weird  
messages like that they internet ip address has changed and that is  
why they were logged out, even though no such thing happed. Also they  
sometimes  get things like the language of Persian selected by default  
  (a few people on the system use Persian) even though they never have  
selected such a thing.
2. Going to places like www.panahi.com shows the index of the main  
directory. Now, apache IS configured not to do that and normally  
automatically loads index.php. This worked perfectly before the  
problems started showing up.
3. Apache is configure to only allow SSL access to certain parts of  
the site. This worked perfectly before the problems started showing  
up. Now, however, it allows non-SSL access to those directories
Those are the main reproducable problems. In trying to solve the  
problem, I rebooted the server several times, I deleted temporary  
files such as those in /tmp, restarted the servers (apache, mysql,  
etc) serveral times. It changed nothing. I finally moved the  
/var/cache/httpd to /var/cache/httpdold so that the  cache would be  
disabled. This fixed EVERYTHING. So it must be the cache, but I can't  
figure out why? It is a problem with 2.0.54? I searched the web and  
mail archives and (unless I searched wrong) could not find a similar  
problem reported. Any help would be appreciated to help me to reenable  
the cache without  causing the problems to appear again. Thanks



-- 
University of Chicago



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message