httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] DirectoryIndex, DirectorySlash and mod_dav?
Date Tue, 11 Jul 2006 21:08:30 GMT
On 7/11/06, Brandon Fosdick <bfoz@bfoz.net> wrote:
> As a quick hack I tried enabling mod_dav on a location to see if it would act as a storage
backend for regular page serving. That is, just to use it for GET and HEAD requests and none
of the other DAV-related requests.
>
> For the most part it works, but for some reason DirectorySlash and DirectoryIndex don't
work in this configuration. If I do http://example.com/mydir/ I get a blank page (no errors),
however http://example.com/mydir/index.html works just fine. My trace log shows that the first
request was handled as a request for the directory instead of a request for mydir/index.html,
so I'm guessing the request wasn't redirected properly before being given to mod_dav.
>
> Any suggestions? Did I miss a directive somewhere? Or is this just un-doable?

Show us the config and log entries.  In general, activating DAV for a
directory shouldn't change anything about GET/HEAD requests.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message