httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harish TM" <harish....@gmail.com>
Subject [users@httpd] Problems with CGI
Date Tue, 11 Jul 2006 20:53:00 GMT
Hi,
        I am having some problems with Ruby CGI code. What I am trying to do
is to use the Ruby WordNet Modules when working with some CGI programs. I
need the CGI program to call a couple of functions defined in a different
module. The CGI program seems to run fine when run from the command line
(offline mode) but when run from a browser it does not load the WordNet
modules.

       Could someone please help out with this.

       I am using wordnet 2.0 Ruby 1.8 apache2 and Suse 9

       I could include the code but there is tons of it so I could include
whatever may be needed ( not sure what that is as of now)


Here is the Apache error log entry.


[Wed Jul 12 01:35:49 2006] [error] [client 192.168.0.34]
/usr/lib64/ruby/site_ruby/1.8/linguistics/en/wordnet.rb:117:in `wnL\exicon':
WordNet functions are not loaded: No such file to load -- wordnet
(NotImplementedError), referer:
http://192.168.0.\34/cgi-bin/TextToTermsStart.rb?name=Harish&account=Account1&theme=Theme1


Interestingly I get the same error when I ssh into the server from a windows
machine (putty) and try to run the program from command line (although the
program works when I run it from the server on command line) Also the
program runs when I ssh into the server from another Linux machine. ( I have
tried to access it through a browser from both windows and Linux and it does
not work )


here is that error msg:


suseserver2:/srv/www/cgi-bin # ruby extract_from_string.rb
/usr/lib64/ruby/site_ruby/1.8/linguistics/en/wordnet.rb:117:in `wnLexicon':
WordNet functions are not loaded: No such file to load -- wordnet
(NotImplementedError)
        from /usr/lib64/ruby/site_ruby/1.8/linguistics/en/wordnet.rb:175:in
`synsets'
        from {Autoloaded:
/usr/lib64/ruby/site_ruby/1.8/linguistics.rb}:98:in `synsets'
        from /usr/lib64/ruby/site_ruby/1.8/linguistics.rb:98:in `call'
        from /usr/lib64/ruby/site_ruby/1.8/linguistics.rb:98:in
`method_missing'
        from extract_from_string.rb:53:in `extractSyn'
        from extract_from_string.rb:87:in `extractPhrase'
        from extract_from_string.rb:211



I thought it had something to do with permissions and have tried changing
them around. Then tried some things with the Apache config, but since the
ssh is not working it looks like that is not the error. I am at a complete
loss...

is there some Wordnet stuff I need to preload


Harish

Mime
View raw message