httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Declerck Michael-W30479" <W30...@motorola.com>
Subject RE: [users@httpd] mod_authnz_ldap for 2.2.2
Date Mon, 31 Jul 2006 19:32:12 GMT
Elaine,
Thank you for your help!

I had already installed Apache once without any modules, so I had
apr-utils installed.
I had been trying to compile and recompile apr-utils because of all the
errors having to do with apr-utils, but was unsuccessful every time.
One problem I had was that apr-utils was being extremely particular
about it's install directory.
In any directory other than /usr/local/apache2, or /usr/local/httpd-apr
and /usr/local/httpd-apr-utils, I would get a complaint stating
explicitly that it could not be installed in my
/home/userName/apache2.2.2 directory.
This complaint/error would occur during the 'make install' process
 
This is was the case, becasue I was using the --prefix to try to install
over my previous Apache install in my home directory.
 
The second problem was those two missing flags, thank you for pointing
me to those otherwise I would have never solved this issue!
--with-ldap-lib=/usr/local/lib and
--with-ldap-include=/usr/local/include.
 
Once you told me about those flags, I started over completely: I went to
a fresh environment with none of my previous env variables set, and
tarred Apache again into a new source directory.
I used those two flags plus all the previous flags:--prefix=(home
directory location) --enable-ldap, --enable-authnz-ldap, --with-ldap,
and also --enable-ssl.
 
The only problem I had then was the apr-utils message which complained
during the 'make install' process just as it had done before.
I took away the prefix flag, allowing Apache to install in the default
location: /usr/local/apache2. 
Result: 0 errors! I checked httpd -l and all the modules are there.
 
I have a few questions about your entry below:

> "./configure" \
> "--prefix=/www/httpd_2.2.2" \
> "--enable-so" \
> "--enable-ssl=shared" \
> "--with-ssl=/usr/local/ssl-httpd2" \
> "--enable-ldap" \
> "--enable-authnz-ldap" \
> "--with-ldap-lib=/usr/local/lib" \
> "--with-ldap-include=/usr/local/include" \
> "--with-ldap" \

What is the --enable-so flag for?
Is the --with-ssl flag pointing to the ssl libraries?
Why is --enable-ssl set to shared? Does that have something to do with
DSO?

Again, thank you very much for your help Elaine,
Micahel DeClerck

________________________________

From: elaine [mailto:elaine@ccuec.unicamp.br] 
Sent: Friday, July 28, 2006 3:03 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] mod_authnz_ldap for 2.2.2



Declerck Michael-W30479 wrote:


	I tried the extra --with-ldap-include and --with-ldap-lib flags,
but I get the same error.
	Do you think this may have to do with the environment variables
CPPFLAGS, CFLAGS, LDFLAGS, and or LD_LIBRARY_PATH?
	See my previous message for what they are set to
(LD_LIBRARY_PATH is set to
/directory/of/previous/apache/install/lib:${LD_LIBRARY_PATH}).
	 
	I have been trying to do the apr-util recompile as listed on the
http://httpd.apache.org/docs/2.2/install.html page.
	The first step on the site (see link above) which is to compile
apr, it compiles _very quickly_ (the make lasts about two lines). 
	Otherwise, this first step compiles without incident into the
previous Apache install folder in my home directory.

I know two ways to solve this problem. I hope them would be useful for
you. 

1)  The first is using bundled apr and apr-util. It means that your
system can't have any
previous apr and apr-util installation in /usr/local (default
installation). If you have, you need to rename them.
After this, you can use all the flags that I've suggested. I recommend
to use "make clean" and "make distclean"
before the new build process.

Below,  my config.nice for example. How to use bundled apr/apr-util :


#! /bin/sh
#
# Created by configure

"./configure" \
"--prefix=/www/httpd_2.2.2" \
"--enable-so" \
"--enable-ssl=shared" \
"--with-ssl=/usr/local/ssl-httpd2" \
"--enable-ldap" \
"--enable-authnz-ldap" \
"--with-ldap-lib=/usr/local/lib" \
"--with-ldap-include=/usr/local/include" \
"--with-ldap" \
"$@"

Note that the three last flags tell to apr/apr-util where are the ldap
libraries :

"--with-ldap-lib=/usr/local/lib" \
"--with-ldap-include=/usr/local/include" \
"--with-ldap" \

2) The second way is using external apr and apr-util installation. In
this case, you can download apr/apr-util
(http://apr.apache.org/download.cgi), or use the bundled sources. I've
been used  the second and followed
the same document at http://httpd.apache.org/docs/2.2/install.html.
Remember that you need apr/apr-util >=
1.2 to apache 2.2.2.

Below,  the three steps that I've been used to install in this way :

a) Build and install apr 1.2 :

# cd /usr/local/src/httpd-2.2.2/srclib/apr
# ./configure
# make
# make install


b) Build and install apr-util 1.2 :

# cd /usr/local/src/httpd-2.2.2/srclib/apr-util
# ./configure \
--with-apr-1=/usr/local/apr \
--with-ldap \
--with-ldap-include=/usr/local/include \
--with-ldap-lib=/usr/local/lib
# make
# make install


c) Build and install apache 2.2.2 (httpd config.nice) :

#! /bin/sh
#
# Created by configure

"./configure" \
"--prefix=/www/httpd_2.2.2" \
"--enable-so" \
"--enable-ssl=shared" \
"--with-ssl=/usr/local/ssl-httpd2" \
"--enable-ldap" \
"--enable-authnz-ldap" \
"$@"

# make
# make install 

I've used in this manner without CPPFLAGS, CFLAGS, LDFLAGS or
LD_LIBRARY_PATH, 
although I've tried to use them also in my effort when I had the same
problem.

Regards,

Elaine



	 
	The second step apr-util configuration runs without incident,
but during the make I get the following error:
	 
	libtool: install: error: cannot install `libaprutil-1.la' to a
directory not ending in /directory/of/previous/apache/install//lib
	make: *** [install] Error 1
	
	despite the prefix flag being set to
/directory/of/previous/apache/install, it seems like it is looking
somewhere else. But I don't know how to tell.
	I'm thinking that I should have never compiled Apache the first
time with a prefix, I have a feeling this has not helped my problems.
	 
	So I tried to compile apache again (with all your suggested
flags below) without the prefix. I experienced the same apr library
errors during the make as listed in my previous email.
	Again, I am not sure if this has anything to do with the
environment variables I have set, to tell you the truth I am not really
sure when or when not to use them.
	The problems seem to pile on top of themselves.
	 
	I thank you for your response, if you have any further advice I
am grateful to hear it.

________________________________

	From: elaine [mailto:elaine@ccuec.unicamp.br] 
	Sent: Friday, July 28, 2006 8:12 AM
	To: users@httpd.apache.org
	Subject: Re: [users@httpd] mod_authnz_ldap for 2.2.2
	
	
	Michael,
	
	Do you have any previous apr installation ? 
	If you don't have, try to use the bundled apr and apr-util that
comes with the apache httpd 
	source releases. To do this, you need to include these options
into your apache configuration:
	
	--enable-ldap
	--enable-authnz-ldap
	--with-ldap-lib=/usr/local/lib
	--with-ldap-include=/usr/local/include
	--with-ldap
	
	Regards,
	Elaine
	  


	Declerck Michael-W30479 wrote:
	

		My current situation of mod_authnz_ldap is still not
good.
		
		The issue was the ldap libraries which I had downloaded
from the
		OpenLDAP source.
		The libraries were being installed in /usr/local/lib.
		I had to point LDFLAGS to -L/usr/local/lib, and CPPFLAGS
and CFLAGS to
		-I/usr/local/include.
		The Apache configure had no errors with these
environment variables.
		
		Unfortunately,
		I get these errors during the Apache make:
		server/.libs/libmain.a(exports.o):(.data+0xe48):
undefined reference to
		`apr_ldap_ssl_init'
		server/.libs/libmain.a(exports.o):(.data+0xe4c):
undefined reference to
		`apr_ldap_ssl_deinit'
		server/.libs/libmain.a(exports.o):(.data+0xe50):
undefined reference to
		`apr_ldap_init'
		server/.libs/libmain.a(exports.o):(.data+0xe54):
undefined reference to
		`apr_ldap_info'
		server/.libs/libmain.a(exports.o):(.data+0xe58):
undefined reference to
		`apr_ldap_get_option'
		server/.libs/libmain.a(exports.o):(.data+0xe5c):
undefined reference to
		`apr_ldap_set_option'
		server/.libs/libmain.a(exports.o):(.data+0xe60):
undefined reference to
		`apr_ldap_is_ldap_url'
		server/.libs/libmain.a(exports.o):(.data+0xe64):
undefined reference to
		`apr_ldap_is_ldaps_url'
		server/.libs/libmain.a(exports.o):(.data+0xe68):
undefined reference to
		`apr_ldap_is_ldapi_url'
		server/.libs/libmain.a(exports.o):(.data+0xe6c):
undefined reference to
		`apr_ldap_url_parse_ext'
		server/.libs/libmain.a(exports.o):(.data+0xe70):
undefined reference to
		`apr_ldap_url_parse'
	
modules/aaa/.libs/libmod_authnz_ldap.a(mod_authnz_ldap.o): In function
	
`mod_auth_ldap_parse_url':mod_authnz_ldap.c:(.text+0x1e84): undefined
		reference to `apr_ldap_url_parse'
		collect2: ld returned 1 exit status
		make[1]: *** [httpd] Error 1
		
		I have very little idea of what to do.
		Any help at all is appreciated.
		
		
		-----Original Message-----
		From: Declerck Michael-W30479 
		Sent: Thursday, July 20, 2006 2:31 PM
		To: users@httpd.apache.org
		Subject: RE: [users@httpd] mod_authnz_ldap for 2.2.2
		
		Kenneth,
		Thank you for the redirect to /usr/lib/apache2/modules/,
I was wondering
		why none of the modules had the .so extension in the
mods-available/
		directory.
		Upon looking in that folder, I found a mod_auth_ldap.so
module which the
		link below suggests was replaced by mod_authnz_ldap in
the Apache2.2
		release.
		
		The documentation said that the most significant change
between 2.0 and
		2.2 was the authorization modules
		(http://httpd.apache.org/docs/2.2/upgrading.html).
		I have been searching around in the Ubuntu Dapper
servertalk and howto
		forums, but have found nothing as yet.
		
		I am going to try to use the mod_auth_ldap.so and see
how the Apache
		takes it.
		I will let you know what happens Kenneth.
		
		If anyone has found anywhere to download standard 2.2
modules such as
		mod_auth_basic, mod_authn_file, mod_authz_user,
mod_authz_groupfile, and
		mod_authnz_ldap please let me know. 
		Your help is always appreciated.
		
		Michael DeClerck
		
		-----Original Message-----
		From: Kenneth Stueflotten Svee
[mailto:k.s.svee@usit.uio.no]
		Sent: Thursday, July 20, 2006 3:43 AM
		To: users@httpd.apache.org
		Subject: Re: [users@httpd] mod_authnz_ldap for 2.2.2
		
		[ Declerck Michael-W30479 ]
		
		  

			Hello,
			I installed Apache2.2.2 several weeks ago on my
Ubuntu Linux machine 
			(which is similar to Debian), and also on my
Windows XP machine. I 
			went to my /etc/apache2/mods-available/
directory looking for the 
			mod_authnz_ldap package which (according to
			http://httpd.apache.org/docs/2.2/mod/) should be
available.
			    

		
		Seems to be an Ubuntu build issue. You should try the
Ubuntu-support
		features (forums and whatnot).
		
		
		  

			However, the mod_authnz_ldap module does not
exist in that directory, 
			nor do many other modules which the Apache
documentation suggests 
			should exist.
			    

		
		The modules them selves are found (on my Ubuntu Dapper)
in
		/usr/lib/apache2/modules/, and haven't found any
mod_authnz_ldap.so
		either. The module is however not enabled by default
when compiling
		Apache2.2, so it may be it's available as an addon, but
a quick
		apt-cache search did not reveal anything. Again, try the
Ubuntu forum.
		
		
		Rgds,
		Kenneth Svee
		
	
---------------------------------------------------------------------
		The official User-To-User support forum of the Apache
HTTP Server
		Project.
		See <URL:http://httpd.apache.org/userslist.html>
<http://httpd.apache.org/userslist.html>  for more info.
		To unsubscribe, e-mail:
users-unsubscribe@httpd.apache.org
		   "   from the digest:
users-digest-unsubscribe@httpd.apache.org
		For additional commands, e-mail:
users-help@httpd.apache.org
		
		
	
---------------------------------------------------------------------
		The official User-To-User support forum of the Apache
HTTP Server
		Project.
		See <URL:http://httpd.apache.org/userslist.html>
<http://httpd.apache.org/userslist.html>  for more info.
		To unsubscribe, e-mail:
users-unsubscribe@httpd.apache.org
		   "   from the digest:
users-digest-unsubscribe@httpd.apache.org
		For additional commands, e-mail:
users-help@httpd.apache.org
		
		
	
---------------------------------------------------------------------
		The official User-To-User support forum of the Apache
HTTP Server Project.
		See <URL:http://httpd.apache.org/userslist.html>
<http://httpd.apache.org/userslist.html>  for more info.
		To unsubscribe, e-mail:
users-unsubscribe@httpd.apache.org
		   "   from the digest:
users-digest-unsubscribe@httpd.apache.org
		For additional commands, e-mail:
users-help@httpd.apache.org
		
		  


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message