httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Hausrath" <hausr...@gmail.com>
Subject Re: [users@httpd] ERROR: ap_proxy_is_word, mod_proxy
Date Sat, 08 Jul 2006 22:38:41 GMT
Hi Rob,

I had a similar issue a few days ago and I finally figured out how to fix
it.  I basically just recompiled apache2 but enabled proxy from the start,
but I installed it to a different directory.  For me it was:

./configure --prefix=/place/to/install --enable-mods-shared=most
--enable-proxy
make
make install

After it installed, I went to the modules directory of the new installation
and copied mod_proxy.so to my existing installation.  It was able to restart
without a problem then.

Hopefully this helps!

-Nate

On 7/7/06, rsosnowski@cableone.net <rsosnowski@cableone.net> wrote:
>
> Using Linux (CentOS 4.2)
>
> Loaded the mod_proxy and proxy_util modules with the following:
>
> /usr/local/apache2/bin/apxs -c -i mod_proxy.c
> /usr/local/apache2/bin/apxs -c -i -n 'APACHE2' proxy_util.c
>
> Edited the httpd.conf file by adding:
>
> LoadModule proxy_module    modules/mod_proxy.so
> LoadModule APACHE2_module  modules/proxy_util.so
>
> When restart apache with:
>
> /usr/local/apache2/bin/apachectl restart
>
> GET THE FOLLOWING ERROR:
> Syntax error on line 238 of /usr/local/apache2/conf/httpd.conf:
> Cannot load /usr/local/apache2/modules/mod_proxy.so into server:
> /usr/local/apache2/modules/mod_proxy.so: undefined symbol: ap_proxy_is_word
>
>
> SUGGESTIONS ON HOW TO RESOLVE, thanks....Rob
>
> --------------------------------------------------------------------- The
> official User-To-User support forum of the Apache HTTP Server Project. See
> for more info. To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org" from the digest:
> users-digest-unsubscribe@httpd.apache.org For additional commands, e-mail:
> users-help@httpd.apache.org
>

Mime
View raw message