httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Bray" <nood...@gmail.com>
Subject Re: [users@httpd] can't get mod_ext_filter to work
Date Mon, 31 Jul 2006 23:26:57 GMT
On 7/31/06, alexander dosher <alyx@pacbell.net> wrote:
> the simplest possible setup, excerpted from httpd.conf:
>
> LoadModule ext_filter_module modules/mod_ext_filter.so
>
> [...]
>
> ExtFilterDefine testFilter mode=output cmd="echo foo"
>
> <Directory "E:/www/httpd/htdocs">
>      Options Indexes
>      AllowOverride None
>
>      Order deny,allow
>      Allow from 63.195.38.230 127.0.0.1
>
>      ExtFilterOptions LogStderr DebugLevel=2
>      SetOutputFilter testFilter
> </Directory>
>
> ...results in the log entry
>
> [error] [client 63.195.38.230] couldn't find definition of filter
> 'testfilter'

Perhaps you used ExtFilterDefine in a vhost context? This isn't
allowed for some reason, and configtest doesn't complain about it.

Also, your Allow from is redundant as "Order deny,allow" means allow by default.

-- 
noodl

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message