httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matus UHLAR - fantomas <uh...@fantomas.sk>
Subject Re: [users@httpd] using another ip-address on multihomed servers
Date Sat, 08 Jul 2006 17:52:04 GMT
On 07.07.06 18:41, Marten Lehmann wrote:
> I have a strange problem: I'm providing a service to my users on a 
> certain ip-address. This service in turn connects to another server.

How? do you use mod_proxy?

> When this service connects to the server it uses the ip-address of the
> http-service defined in a virtual host entry. I usually can change the
> LocalAddr when I'm connecting to a server,

if you connecting from the machine using telnet or similar pgoram (not
apache?)

> but this doesn't work when it is done through apache.

I'm afraid apache does not have that feature. maybe you could submit a
wishlist bugreport...

> When I'm doing this
> locally (without the webserver) it works.
> 
> What is the reason for it? Might it be a problem that apache runs as nobody?

it probably doesn't have anything with the user, unless you have kernel
patch that denies using source IP addresses
-- 
Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
99 percent of lawyers give the rest a bad name. 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message