httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nes Yarug" <nes.ya...@gmail.com>
Subject [users@httpd] balancer proxy with http and https
Date Wed, 19 Jul 2006 19:55:18 GMT
Hi,

I've been trying to configure Apache's balancer proxy, but have not had any
luck. I've been trying to configure a load balancing proxy that forwards
requests to 2 web servers. I want both http and https requests to be
forwarded.

I started with the following configuration in /etc/apache/httpd.conf:

ProxyPass /awstats !
ProxyPass /balancer-manager !
ProxyPass / balancer://mycluster/ stickysession=jsessionid
ProxyPreserveHost On

<Proxy balancer://mycluster/>
BalancerMember http://192.168.0.2:80
BalancerMember http://192.168.0.3:80
</Proxy>

This worked fine, but ofcourse not for https requests. I then removed the
above configuration from httpd.conf and placed it in the default vhost
configuration at /etc/apache2/vhosts.d/00_default_vhost.conf:

ProxyPass /awstats !
ProxyPass /balancer-manager !
ProxyPass / balancer://mycluster/ stickysession=jsessionid
ProxyPreserveHost On

<Proxy balancer://mycluster/>
BalancerMember http://192.168.0.2:80
BalancerMember http://192.168.0.3:80
</Proxy>

I then configured the default ssl virtual host simularly
(/etc/apache2/modules.d/41_mod_ssl.default-vhost.conf):

ProxyPass / balancer://mysslcluster/ stickysession=jsessionid
ProxyPreserveHost On

<Proxy balancer://mysslcluster/>
BalancerMember https://192.168.0.2:443
BalancerMember https://192.168.0.3:443
</Proxy>

But now I cannot get my requests to the balancer handled by one of the web
servers (i.e. the request is not forwarded). An http request is forwarded to
the web servers, but an https request is giving an Internal Server Error.

Can someone please comment on the above configuration and tell me what I'm
doing wrong?

Many thanks,
Nes

Mime
View raw message