httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike - EMAIL IGNORED <m_d_berger_1...@yahoo.com>
Subject [users@httpd] Re: RE: /my.html#mySection
Date Tue, 20 Jun 2006 23:03:56 GMT
On Tue, 20 Jun 2006 08:42:33 -0600, David Salisbury wrote:

[...]
>> 
>>> Additionally, I wonder why the #ZZZ appeared in the first place.
>> 
>> a bug in the client I guess, I've seen this problem in some proxy server's
>> mailing list...
> 
> I would guess all that happened was the user bookmarked the page with the anchor.
> I can't imagine it's a security problem.
> 
> 
> -ds
> 
[...]

I just tried the bookmarking idea with both Firefox and Internet
Explorer. In each case, I went to a page and an anchor in the middle, and
bookmarked. I then closed the browser, reopened, and selected the
bookmark.  In each case, the correct display appeared.  In neither case
did the anchor (#ZZZ) appear in the httpd log.  Since my CGI sends 403 if
it sees #ZZZ, we can safely assume that the browsers did not send it.

The occasional appearance of #ZZZ in my logs therefore still remains
a mystery.  By the way, I can duplicate it if I use nc on another
Linux box to send an (in)appropriate GET.

Mike.



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message