httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] mod_actions
Date Mon, 26 Jun 2006 16:00:30 GMT
On 6/26/06, Ludovic Beliveau (QB/EMC) <ludovic.beliveau@ericsson.com> wrote:

> I can't make mod_actions works for apache version 2.0 and 2.2.
>
> I've added the following two lines in my httpd.conf file:
> AddHandler sdp-file-type .sdp
> Action sdp-file-type /cgi-bin/gen.cgi
>
> Whenever I try to access an .sdp file, I get a 404 not found error.
>
> In case you're wondering, the cgi script works and with server-info I see my
> action defined.  Also, on a machine running apache 1.3, the same config
> works.
>
> Can somebody has a clue about how I could fix this ?  Or is there another
> way I could do this (I simply wants all request for files .sdp to be
> redirected to a cgi script) ?

Check the 2.2 docs:
http://httpd.apache.org/docs/2.2/mod/mod_actions.html

Look in particular at the "virtual" keyword.

Or alternatively, just use mod_rewrite to map these requests.

(And yes, this was a change in behavior from 1.3 to 2.0.  But my
opinion is that the new behavior is better.)

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message