httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Yu <...@tuckerenergy.com>
Subject [users@httpd] Apache does not connect to MySQL
Date Mon, 26 Jun 2006 16:48:00 GMT
Hi,

I tried to set up an Apache server on Fedora Core 5. When I installed the system, I did select
the php-mysql.
But after installation, my php application can not connect MySQL server, I got : "Couldn't
connect to the
server : 127.0.0.1". And from the phpinfo() also shows : 'without-mysql'. The MySQL server
is working.

The system was :

Linux core : 2.6.16-1.2133_FC5
Apache     : 2.2.0
MySQL      : 5.0.22
PHP        : 5.1.4

Then I added 'extension=mysql.so' to php.ini. The Apache server worked fine. And php could
connect to MySQL.

After I did a system update, it failed again. Even I added the same "extension=mysql.so" to
php.ini. My php application
still can't connect to MySQL.

Now my system is:

Linux core : 2.6.16-1.2289_FC6   // does this mean Fedora Core 6?
Apache     : 2.2.2
MySQL      : 5.0.22
PHP        : 5.1.4

What's the problem?

Thanks,

Marcus


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message