httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hamad S. Al-Jalaq" <hamad.ja...@sitcon.com>
Subject RE: [users@httpd] Apache 2.2 not working with PHP4
Date Sun, 11 Jun 2006 15:40:43 GMT
I am not professional in apache and PHP, but I've done as per the
installation steps... I am installing it on windows 2003... please could
you check the attached file?

Thanks,

Hamad

-----Original Message-----
From: Josh Stephenson [mailto:josh@clearwired.com] 
Sent: Sunday, June 11, 2006 6:23 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Apache 2.2 not working with PHP4

You need to edit your httpd.conf file to handle php files

add these lines and you should be good:

LoadModule php4_module libexec/apache2/libphp4.so
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps


The first line might already be in there, but the second one not being 
there is definitely the reason apache is sending the php file to your 
browser for download.

Don't forget to restart apache:
apachectl graceful


Hamad S. Al-Jalaq wrote:
>
> I've installed apache version 2.x with PHP4.3.0... configured at as an

> apache module... but when try to visit the index.php file the browser 
> asks me if I want to download the file... it suppose to browse the
file 
> not download it... please advice...
>
> Thanks,
>
> Hamad
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org




Mime
View raw message