httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Berizzi" <pupi...@hotmail.com>
Subject [users@httpd] proxy: error reading status line from remote server
Date Wed, 17 May 2006 13:03:20 GMT
Hello everybody.
I'm try to build a reverse proxy for outlook web access
2003sp2 running on windows 2003 sp1.
apache 1.3.35 is running good with this configuration:

<VirtualHost *>
    ServerAdmin postmaster@domain.you
    ServerName mail.domain.you

    ErrorLog /var/log/apache/error_http_owa_log

    ProxyPass /exchange http://mail.domain.you/exchange/
    ProxyPassReverse /exchange/ http://mail.domain.you/exchange/
    ProxyPass /exchweb http://mail.domain.you/exchweb/
    ProxyPassReverse /exchweb http://mail.domain.you/exchweb/
    ProxyPass /public http://mail.domain.you/public/
    ProxyPassReverse /public http://mail.domain.you/public/
</VirtualHost>

The same config with apache 2.2.2 doesn't work. I'm getting
these errors:

[Wed May 17 14:36:14 2006] [error] [client 172.16.0.118] proxy: error 
reading status line from remote server mail.domain.you, referer: 
http://mail.domain.you/exchange/lmoggi/?Cmd=navbar
[Wed May 17 14:36:14 2006] [error] [client 172.16.0.118] proxy: Error 
reading from remote server returned by /exchange/lmoggi/Inbox, referer: 
http://mail.domain.you/exchange/lmoggi/?Cmd=navbar
[Wed May 17 14:36:40 2006] [error] [client 172.16.0.118] proxy: error 
reading status line from remote server mail.domain.you
[Wed May 17 14:36:40 2006] [error] [client 172.16.0.118] proxy: Error 
reading from remote server returned by /exchange/lmoggi/Inbox/R: cucca 
figo-7.EML
[Wed May 17 14:36:50 2006] [error] [client 172.16.0.118] proxy: error 
reading status line from remote server mail.domain.you
[Wed May 17 14:36:50 2006] [error] [client 172.16.0.118] proxy: Error 
reading from remote server returned by /exchange/lmoggi/Inbox/R: cucca 
figo-6.EML

the problem is workarounded adding 'SetEnv
proxy-nokeepalive 1' to the virtualhost
section, or removing the flag 'Enable HTTP
Keep-Alives' in the IIS manager on windows
2003.
Is there any incompatibilities between
windows 2003sp1 and mod_proxy from apache
2.2.2 with keepalive=on?
Why apache 1.3.35 is working fine with
windows 2003sp1 and keealive=on?



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message