httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Zitnik" <JZit...@hfcc.net>
Subject Re: [users@httpd] Apache error
Date Tue, 30 May 2006 12:59:43 GMT
>>> On 5/30/2006 at 8:44 AM, hillardn@whl.co.uk wrote:
Hi,

Joe Zitnik wrote:
> Hello all.  After applying some patches to a SuSE SLES 8 box, I get
the
> following error when trying to start apache.
>  
> Starting httpd []
>  
> [Fri May 26 12:20:28 2006] [warn] Apache does not support line-end
> comments.
> Consider using quotes around argument: "#-1"
> Syntax error on line 633 of /etc/httpd/httpd.conf:
> Invalid command 'AddIconByType', perhaps mis-spelled or defined by a
> module
> not included in the server configuration
> ..failed
>  
> I get this error on any one of a dozen different lines in the
> httpd.conf file.  All of the lines seem to be related to the
> mod_autoindex module.  I googled the error and found some mail list
> responses about the same error where the solution was to manually
add
> the load module line to the httpd.conf file.  I tried this with no
> success.  Does anyone have any suggestions or solutions I could try?

First of all, tell us what those lines actually say and secondly the
error message is probably correct.  Do those lines have comments at
the
line end (in which case remove them and try again)?

Tell us exactly what you tried and the config lines you used.


Neil.

-- 
Neil Hillard                    hillardn@whl.co.uk 
Westland Helicopters Ltd.       http://www.whl.co.uk/ 

Disclaimer: This message does not necessarily reflect the
            views of Westland Helicopters Ltd.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org 
   "   from the digest: users-digest-unsubscribe@httpd.apache.org 
For additional commands, e-mail: users-help@httpd.apache.org 


This was a previously working install of Apache, until the patches were
applied.  Like I said, it gives errors on several lines of the conf file
now.  Here are some of them:
 
#
# Controls who can get stuff from this server.
#
    Order allow,deny
    Allow from all
 
</Directory>
 
I will get errors saying "Order"  perhaps mis-spelled or defined by a
module not included in the server configuration
 
Here are the AddIconByType lines:
 
AddIconByType (TXT,/icons/text.gif) text/*
AddIconByType (IMG,/icons/image2.gif) image/*
AddIconByType (SND,/icons/sound2.gif) audio/*
AddIconByType (VID,/icons/movie.gif) video/*
 
I posted to the OS list (SLES) and had someone request my httpd.conf
file.  They reviewed it and said all looked to be in order.  I figured I
would now post to the apache specialists.  Thanks for any help anyone
can provide.

 

Mime
View raw message