httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From WDaquell <wdaqu...@gmail.com>
Subject Re: [users@httpd] Getting Apache to use PHP under Window XP
Date Tue, 30 May 2006 04:23:36 GMT
Have you tried putting PHP.ini in your Windows folder? I had to do that 
before PHP would work on my system.

-Wraith

Martyn Griffin wrote:
>  Overview:
>
> I am trying to change the httpd.conf file to add the LoadModule command for
> PHP V5.1.4.
>
> The instructions indicate to make a reference to the .dll file (not an .SO
> file).
> Here is the line that was added:
>
> LoadModule php5_module modules/php5apache2.dll
>
> The dll file has been moved to the Apache2.2 modules folder for this
> attempt.
>
> After apache startup fails, the Application Event log contains an error msg
> with the following:
>
> The Apache service named  reported the following error:
>   
>>>> httpd.exe: Syntax error on line 70 of C:/Program Files/Apache Software
>>>>         
> Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/Program Files/Apache
> Software Foundation/Apache2.2/modules/php5apache2.dll into server: The
> specified procedure could not be found.     .
>
> Apache works as expected without this line added (but without any PHP
> support) and PHP itself works (though not thoroughly tested).
>
> Also, a system environment variable  (PHPRC) was set to point to the folder
> containing the PHP.ini file.
>
> No doubt, I will need to supply more info, but was hoping someone might just
> have the answer at the tip of their tongue :^)
>
> Martyn T. Griffin
>
>   


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message