httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Praveen Alavilli <Praveen1...@aol.com>
Subject [users@httpd] Problem with Satisfy Directive
Date Wed, 24 May 2006 13:13:08 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
<font size="-1"><font face="Comic Sans MS">I am trying to let bots
crawl my site with out requiring to authentication but it doesn't work
for some reason. It doesn't even enforce the Basic auth if the
user-agent doesn't match "Googlebot" even though I have <b>Satisfy Any
</b>!!<br>
<br>
<b>BrowserMatchNoCase Robot is_robot<br>
&lt;Location /content/*&gt;<br>
&nbsp;&nbsp;&nbsp; AuthUserFile /home/conf/htpasswords<br>
&nbsp;&nbsp;&nbsp; AuthName "Restricted Access"<br>
&nbsp;&nbsp;&nbsp; AuthType Basic<br>
&nbsp;&nbsp;&nbsp; Require valid-user<br>
&nbsp;&nbsp;&nbsp; Allow from env=is_</b></font></font><b><font
size="-1"><font
 face="Comic Sans MS">robot</font></font><br>
</b><font size="-1"><font face="Comic Sans MS"><b>&nbsp;&nbsp;&nbsp;</b><b>
Satisfy Any<br>
&lt;/Location&gt;</b><br>
<br>
<br>
thanks for any help<br>
Praveen<br>
</font></font>
</body>
</html>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message