httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Jones" <tetragondz...@gmail.com>
Subject Re: [users@httpd] SSL Problem Still not Solved in Apache2-RHEL4
Date Tue, 16 May 2006 13:45:11 GMT
On 5/16/06, Rex Brooks <rexb@starbourne.com> wrote:

>
> openssl rsa -in server.key.orig -out server.key

OK; sorry.

> also the chmod 0400 should be chmod 400, but neither of those

It's octal so 0400 is correct but 400 and 0400 are the same  =)

> impacted the results: The passphrase was removed but httpd still
> failed to start.

Theres another issue then with possibly one of the other modules you
want to run...  Can you try to start with both or either disabled to
see if SSL comes up?

> We KNOW mod_ssl is at fault here, since, beyond the error message,

Are we so sure that when all else fails ssl is at fault?  =)

> httpd starts when mod_ssl is removed. We also know that when it is
> removed the VirtualHosts won't accept connections. AND, it appears
> that the PassPhrase is not responsible. (Note, I said, appears, since
> I am wondering if I actually need to be logged in as my user and then
> become root, instead of being logged in as root, which I have been?)

Logged in as root is required to 'start' apache  -- what ID does it run as?

> Regardless, there ought to be a process of elimination which will
> isolate the culprit in here somewhere.

I would try it with SSl only as see if it works, then slowly add each
additional requirement to see what breaks, etc.

-- 
WC (Bill) Jones -- http://youve-reached-the.endoftheinternet.org/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message