httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wijaya Edward <ewij...@i2r.a-star.edu.sg>
Subject [users@httpd] Howto find locally installed Perl Module by .htaccess ?
Date Fri, 19 May 2006 02:16:58 GMT

Hi expert,

I have the following simple CGI script, just containg header:


__BEGIN__
#!/usr/bin/perl -w
use CGI ':standard';
use lib "/home/myname/lib/perl5/site_perl/5.8.5/";
use Mail::Sendmail;
__END__

I also have included this directive in ~/public_html/.htaccess :

SetEnv PERL5LIB /home/myname/lib/perl5/site_perl/5.8.5


Since I am not a root user I have installed my module locally
as shown in the directive above.

Now the problem is that my CGI script above (called temp.cgi)
cannot recognize the location of my Perl module.
You can try it here:

http://defiant.i2r.a-star.edu.sg/~ewijaya/MyTest/cgi-bin/temp.cgi


Also in command line: $perl -cT temp.cgi
gave same problem of failure in recognizing Mail::Sendmail.

What's wrong with my setup? How can I let my cgi script
recognize the Mail::Sendmail module?

Hope to hear from you again.

--
Regards,
Edward WIJAYA
SINGAPORE



------------ Institute For Infocomm Research - Disclaimer -------------
This email is confidential and may be privileged.  If you are not the intended recipient,
please delete it and notify us immediately. Please do not copy or use it for any purpose,
or disclose its contents to any other person. Thank you.
--------------------------------------------------------

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message