httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rassilka <r...@iriit.irk.ru>
Subject [users@httpd] problem with authnz-ldap (httpd 2.2.0, FreeBSD 6.1)
Date Thu, 04 May 2006 03:12:23 GMT
Hi!
When i compile, all good. But, when i try start apache, i receive this error

/libexec/ld-elf.so.1: /usr/local/apache2/bin/httpd: Undefined symbol "apr_ldap_url_parse"

What wrong?
config is:
<skip>
    AuthType Basic
      AuthName "Auth Zone"
      AuthLDAPUrl ldap://172.16.2.1/o=rrr
      require ldap-group cn=sa002,ou=spec,ou=soft,o=iriit
<skip>
----------------------------
apache compile:
env CPPFLAGS=-I/usr/local/include CPPFLAGS=-I/usr/local/apr/include LDFLAGS=-L/usr/local/lib
./configure \
  --with-apr=/usr/local/apr \
  --with-apr-util=/usr/local/apr \
  --enable-authnz-ldap \
  --enable-ldap \
  --with-ldap-lib=/usr/local/lib \
  --with-ldap-include=/usr/local/include \
  --enable-so
----------------------
also compile
 apr-1.2.7
 apr-util-1.2.7
 openldap-2.3.20
without any errors

-- 
Igor V Rozinov
IrGUPS, Russia
mailto:rass@iriit.irk.ru


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message