httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martyn Griffin" <griffi...@charter.net>
Subject RE: [users@httpd] Getting Apache to use PHP under Window XP
Date Thu, 01 Jun 2006 00:07:25 GMT
It is where it is specified. But I have moved  it around a bit, into the
modules folder and just specifying  modules/php5apache.dll but same failure.
I have tried various combinations of absolute and relative paths, tried
adding quotes and without, renamed the dll to .so etc etc
In all cases I get this same error. But all the other modules seem to load
ok.
I even pulled the dll out of the distribution zip file again and retried and
it still fails.
 
If anyone has this running (PHP 5.1.4 and Apache 2.2), could you show the
relevant entries from your .conf file etc.
 
Thanks,
Martyn T. Griffin 
 

   _____  

From: Bill Angus [mailto:mdangus@psychtest.com] 
Sent: Tuesday, May 30, 2006 12:08 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Getting Apache to use PHP under Window XP


Marty: 
 
On Win2k, I had to use the syntax with the fully qualified pathname in it --
i.e. your ... 
 
LoadModule php5_module "C:/Installs/WebTools/PHP/php5apache2.dll"
... looks right to me as long as php5apache2.dll is actually in the
directory you have specified :)
 
For Apache 2.2 my syntax is 
LoadModule php5_module "C:\php\php5apache2_2.dll"
 
Bill Angus, MA
HYPERLINK "http://www.psychtest.com"http://www.psychtest.com

----- Original Message ----- 
From: HYPERLINK "mailto:griffinmt@charter.net"Martyn Griffin 
To: HYPERLINK "mailto:users@httpd.apache.org"users@httpd.apache.org 
Sent: Tuesday, May 30, 2006 6:52 AM
Subject: RE: [users@httpd] Getting Apache to use PHP under Window XP


Have been trying a few things more and actually noticed what may be a key
difference in the error msgs logged.
When I use the entry:
LoadModule php5_module modules/php5apache2.dll
It returns the error --> The specified procedure could not be found.     .

When I use the full path to the original file as:
With or without the quotes, it returns --> The specified module could not be
found.     .

The only difference in the structure of the error message is that one uses
the word MODULE and the other uses PROCEDURE.

Is it probable that these are two distinct issues, one not able to open the
file and the other, not liking what it sees (or doesn't see) after it is
opened??


Martyn T. Griffin


-----Original Message-----
From: Martyn Griffin [mailto:griffinmt@charter.net] 
Sent: Tuesday, May 30, 2006 9:01 AM
To: HYPERLINK "mailto:users@httpd.apache.org"users@httpd.apache.org
Subject: RE: [users@httpd] Getting Apache to use PHP under Window XP

The problem is with the php interface module. But, just to make sure, I put
a copy into the windows folder and retried, to no avail.

Is it possible I have an access issue. I am running on XP Home. If so, how
do I alter that. Since this is an internal Lan system, I could open up
everything for now. 


Martyn T. Griffin


-----Original Message-----
From: WDaquell [mailto:wdaquell@gmail.com]
Sent: Tuesday, May 30, 2006 12:24 AM
To: HYPERLINK "mailto:users@httpd.apache.org"users@httpd.apache.org
Subject: Re: [users@httpd] Getting Apache to use PHP under Window XP

Have you tried putting PHP.ini in your Windows folder? I had to do that
before PHP would work on my system.

-Wraith

Martyn Griffin wrote:
>  Overview:
>
> I am trying to change the httpd.conf file to add the LoadModule 
> command for PHP V5.1.4.
>
> The instructions indicate to make a reference to the .dll file (not an 
> .SO file).
> Here is the line that was added:
>
> LoadModule php5_module modules/php5apache2.dll
>
> The dll file has been moved to the Apache2.2 modules folder for this 
> attempt.
>
> After apache startup fails, the Application Event log contains an 
> error msg with the following:
>
> The Apache service named  reported the following error:
>   
>>>> httpd.exe: Syntax error on line 70 of C:/Program Files/Apache 
>>>> Software
>>>>         
> Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/Program 
> Files/Apache Software Foundation/Apache2.2/modules/php5apache2.dll 
> into
server: The
> specified procedure could not be found.     .
>
> Apache works as expected without this line added (but without any PHP
> support) and PHP itself works (though not thoroughly tested).
>
> Also, a system environment variable  (PHPRC) was set to point to the 
> folder containing the PHP.ini file.
>
> No doubt, I will need to supply more info, but was hoping someone 
> might just have the answer at the tip of their tongue :^)
>
> Martyn T. Griffin
>
>   
/snip


--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.7.4/351 - Release Date: 5/29/2006



-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.0/352 - Release Date: 5/30/2006
 

Mime
View raw message