httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From living liquid | Christian Meisinger <c.meisin...@livingliquid.com>
Subject Re: [users@httpd] SSLPassPhraseDialog exec problem
Date Thu, 20 Apr 2006 07:43:37 GMT
no one out there with a tip for me? :)


> hi!
> 
> i try to upgrade from apache 1.3.x to
> apache 2.0.55.
> 
> for apache 1.3 i used SSLPassPhraseDialog exec and it works perfectly.
> 
> the problem with apache 2 is:
> [Tue Apr 18 11:49:59 2006] [info] Init: Requesting pass phrase from
> dialog filter program (...)
> [Tue Apr 18 11:49:59 2006] [error] Init: Pass phrase incorrect
> 
> when i use SSLPassPhraseDialog builtin it works.
> 
> User and Group for apache2 is nobody:nogroup (#-1)
> the shell script for SSLPassPhraseDialog root.root 555 so 'nobody'
> can execute it (and i verified that).
> 
> i also tried to chown the script to nobody.nogroup. no difference
> 
> then i added some more log output into the ssl_engine_pphrase.c and
> compiled apache again.
> until now it seems so either apache can't execute the script
> (also i don't get an error) or it can't read the output (the buffer
> returned from reading the output of the script is empty, no error
> here too).
> 
> i'm really confused :(
> 
> what's the difference between apache1 SSLPassPhraseDialog and the
> apache2 version???
> 
> 
> 	best regards christian


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message