httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Larry Flathmann <market...@elrancho.com.mx>
Subject Re: [users@httpd] Editing the conf breaks my server
Date Tue, 04 Apr 2006 16:47:42 GMT
Could you copy and paste the relevant section from your httpd.conf file, 
just to double check?

Also, have you tried accessing specific files to see if they will load? 
I.e., http://localhost/index.htm instead of just localhost? Maybe you 
need to change your DirectoryIndex directive.

--Larry

Paul wrote:
> yes and yes
>
> On 4/4/06, *Larry Flathmann* <marketing@elrancho.com.mx 
> <mailto:marketing@elrancho.com.mx>> wrote:
>
>     When you did hte install before changing the config file, did it work?
>     Were you able to see the Apache "everything installed ok..." page?
>
>     --Larry
>
>     Paul wrote:
>     > HI larry
>     >
>     > I used the default httpd.conf file that comes with the install with
>     > the exception of 2 changes ( ie changing the document path )
>     >
>     > Even when I changed them back to the default settings theproblem was
>     > still occuring
>     >
>     >
>     > Its listening on port 80 as a service and no other conflicting
>     > services or software is present
>     >
>     > On 4/4/06, *Larry Flathmann* < marketing@elrancho.com.mx
>     <mailto:marketing@elrancho.com.mx>
>     > <mailto:marketing@elrancho.com.mx
>     <mailto:marketing@elrancho.com.mx>>> wrote:
>     >
>     >     Hi Paul,
>     >
>     >     Your log file doesn't indicate anything out of hte normal.
>     >
>     >     Have you tried just viewing the default page that comes with the
>     >     Apache
>     >     install, the one that says "If you can see this, it means
>     that the
>     >     installation of the Apache web server
>     >     < http://www.apache.org/foundation/preFAQ.html> software on this
>     >     system
>     >     was successful. You may now add content to this directory
>     and replace
>     >     this page." Did that work? If so, then send your httpd.conf
>     file,
>     >     because there's got to be some detail that's messed up.
>     >
>     >     One other possibility that comes to mind is whether you've
>     configured
>     >     Apache to listen on the right address (localhost, or your
>     local IP, or
>     >     whatever)
>     >
>     >     --Larry
>     >
>     >     Paul wrote:
>     >     > Thanks Larry
>     >     >
>     >     >
>     >     > I am not sure how to read the log files so here it is
>     >     >
>     >     > [Mon Apr 03 22:55:38 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 22:55:38 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     > [Mon Apr 03 22:55:38 2006] [notice] Parent: Created child
>     >     process 3908
>     >     > [Mon Apr 03 22:55:38 2006] [notice] Child 3908: Child
>     process is
>     >     running
>     >     > [Mon Apr 03 22:55:38 2006] [notice] Child 3908: Acquired the
>     >     start mutex.
>     >     > [Mon Apr 03 22:55:38 2006] [notice] Child 3908: Starting
>     250 worker
>     >     > threads.
>     >     > [Mon Apr 03 23:01:41 2006] [notice] Parent: Received restart
>     >     signal --
>     >     > Restarting the server.
>     >     > [Mon Apr 03 23:01:41 2006] [notice] Child 3908: Exit event
>     signaled.
>     >     > Child process is ending.
>     >     > [Mon Apr 03 23:01:41 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 23:01:41 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     > [Mon Apr 03 23:01:41 2006] [notice] Parent: Created child
>     >     process 4020
>     >     > [Mon Apr 03 23:01:41 2006] [notice] Child 4020: Child
>     process is
>     >     running
>     >     > [Mon Apr 03 23:01:42 2006] [notice] Child 3908: Released the
>     >     start mutex
>     >     > [Mon Apr 03 23:01:42 2006] [notice] Child 4020: Acquired the
>     >     start mutex.
>     >     > [Mon Apr 03 23:01:42 2006] [notice] Child 4020: Starting
>     250 worker
>     >     > threads.
>     >     > [Mon Apr 03 23:01:43 2006] [notice] Child 3908: Waiting
>     for 250
>     >     worker
>     >     > threads to exit.
>     >     > [Mon Apr 03 23:01:43 2006] [notice] Child 3908: All worker
>     threads
>     >     > have exited.
>     >     > [Mon Apr 03 23:01:43 2006] [notice] Child 3908: Child
>     process is
>     >     exiting
>     >     > [Mon Apr 03 23:01:43 2006] [notice] Parent: Received restart
>     >     signal --
>     >     > Restarting the server.
>     >     > [Mon Apr 03 23:01:43 2006] [notice] Child 4020: Exit event
>     >     signaled.
>     >     > Child process is ending.
>     >     > [Mon Apr 03 23:01:43 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 23:01:44 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     > [Mon Apr 03 23:01:44 2006] [notice] Parent: Created child
>     >     process 4228
>     >     > [Mon Apr 03 23:01:44 2006] [notice] Child 4228: Child
>     process is
>     >     running
>     >     > [Mon Apr 03 23:01:44 2006] [notice] Child 4228: Acquired the
>     >     start mutex.
>     >     > [Mon Apr 03 23:01:44 2006] [notice] Child 4020: Released the
>     >     start mutex
>     >     > [Mon Apr 03 23:01:45 2006] [notice] Child 4228: Starting
>     250 worker
>     >     > threads.
>     >     > [Mon Apr 03 23:01:46 2006] [notice] Child 4020: Waiting
>     for 250
>     >     worker
>     >     > threads to exit.
>     >     > [Mon Apr 03 23:01:46 2006] [notice] Child 4020: All worker
>     threads
>     >     > have exited.
>     >     > [Mon Apr 03 23:01:46 2006] [notice] Child 4020: Child
>     process is
>     >     exiting
>     >     > [Mon Apr 03 23:05:19 2006] [notice] Parent: Received restart
>     >     signal --
>     >     > Restarting the server.
>     >     > [Mon Apr 03 23:05:19 2006] [notice] Child 4228: Exit event
>     signaled.
>     >     > Child process is ending.
>     >     > [Mon Apr 03 23:05:19 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 23:05:19 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     > [Mon Apr 03 23:05:19 2006] [notice] Parent: Created child
>     >     process 4220
>     >     > [Mon Apr 03 23:05:19 2006] [notice] Child 4220: Child
>     process is
>     >     running
>     >     > [Mon Apr 03 23:05:20 2006] [notice] Child 4228: Released the
>     >     start mutex
>     >     > [Mon Apr 03 23:05:20 2006] [notice] Child 4220: Acquired the
>     >     start mutex.
>     >     > [Mon Apr 03 23:05:20 2006] [notice] Child 4220: Starting
>     250 worker
>     >     > threads.
>     >     > [Mon Apr 03 23:05:21 2006] [notice] Child 4228: Waiting
>     for 250
>     >     worker
>     >     > threads to exit.
>     >     > [Mon Apr 03 23:05:21 2006] [notice] Child 4228: All worker
>     threads
>     >     > have exited.
>     >     > [Mon Apr 03 23:05:21 2006] [notice] Child 4228: Child
>     process is
>     >     exiting
>     >     > [Mon Apr 03 23:07:00 2006] [notice] Parent: Received restart
>     >     signal --
>     >     > Restarting the server.
>     >     > [Mon Apr 03 23:07:00 2006] [notice] Child 4220: Exit event
>     >     signaled.
>     >     > Child process is ending.
>     >     > [Mon Apr 03 23:07:00 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 23:07:00 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     > [Mon Apr 03 23:07:00 2006] [notice] Parent: Created child
>     >     process 3008
>     >     > [Mon Apr 03 23:07:00 2006] [notice] Child 3008: Child
>     process is
>     >     running
>     >     > [Mon Apr 03 23:07:01 2006] [notice] Child 4220: Released the
>     >     start mutex
>     >     > [Mon Apr 03 23:07:01 2006] [notice] Child 3008: Acquired the
>     >     start mutex.
>     >     > [Mon Apr 03 23:07:01 2006] [notice] Child 3008: Starting
>     250 worker
>     >     > threads.
>     >     > [Mon Apr 03 23:07:02 2006] [notice] Child 4220: Waiting
>     for 250
>     >     worker
>     >     > threads to exit.
>     >     > [Mon Apr 03 23:07:02 2006] [notice] Child 4220: All worker
>     threads
>     >     > have exited.
>     >     > [Mon Apr 03 23:07:02 2006] [notice] Child 4220: Child
>     process is
>     >     exiting
>     >     > [Mon Apr 03 23:09:18 2006] [notice] Parent: Received restart
>     >     signal --
>     >     > Restarting the server.
>     >     > [Mon Apr 03 23:09:18 2006] [notice] Child 3008: Exit event
>     signaled.
>     >     > Child process is ending.
>     >     > [Mon Apr 03 23:09:18 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 23:09:18 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     > [Mon Apr 03 23:09:18 2006] [notice] Parent: Created child
>     >     process 2708
>     >     > [Mon Apr 03 23:09:19 2006] [notice] Child 2708: Child
>     process is
>     >     running
>     >     > [Mon Apr 03 23:09:19 2006] [notice] Child 3008: Released the
>     >     start mutex
>     >     > [Mon Apr 03 23:09:19 2006] [notice] Child 2708: Acquired the
>     >     start mutex.
>     >     > [Mon Apr 03 23:09:19 2006] [notice] Child 2708: Starting
>     250 worker
>     >     > threads.
>     >     > [Mon Apr 03 23:09:20 2006] [notice] Child 3008: Waiting
>     for 250
>     >     worker
>     >     > threads to exit.
>     >     > [Mon Apr 03 23:09:20 2006] [notice] Child 3008: All worker
>     threads
>     >     > have exited.
>     >     > [Mon Apr 03 23:09:20 2006] [notice] Child 3008: Child
>     process is
>     >     exiting
>     >     > [Mon Apr 03 23:09:48 2006] [notice] Parent: Received restart
>     >     signal --
>     >     > Restarting the server.
>     >     > [Mon Apr 03 23:09:48 2006] [notice] Child 2708: Exit event
>     >     signaled.
>     >     > Child process is ending.
>     >     > [Mon Apr 03 23:09:48 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 23:09:48 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     > [Mon Apr 03 23:09:48 2006] [notice] Parent: Created child
>     >     process 4472
>     >     > [Mon Apr 03 23:09:48 2006] [notice] Child 4472: Child
>     process is
>     >     running
>     >     > [Mon Apr 03 23:09:49 2006] [notice] Child 2708: Released the
>     >     start mutex
>     >     > [Mon Apr 03 23:09:49 2006] [notice] Child 4472: Acquired the
>     >     start mutex.
>     >     > [Mon Apr 03 23:09:49 2006] [notice] Child 4472: Starting
>     250 worker
>     >     > threads.
>     >     > [Mon Apr 03 23:09:50 2006] [notice] Child 2708: Waiting
>     for 250
>     >     worker
>     >     > threads to exit.
>     >     > [Mon Apr 03 23:09:50 2006] [notice] Child 2708: All worker
>     threads
>     >     > have exited.
>     >     > [Mon Apr 03 23:09:50 2006] [notice] Child 2708: Child
>     process is
>     >     exiting
>     >     > [Mon Apr 03 23:10:01 2006] [notice] Parent: Received restart
>     >     signal --
>     >     > Restarting the server.
>     >     > [Mon Apr 03 23:10:01 2006] [notice] Child 4472: Exit event
>     signaled.
>     >     > Child process is ending.
>     >     > [Mon Apr 03 23:10:01 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 23:10:01 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     > [Mon Apr 03 23:10:01 2006] [notice] Parent: Created child
>     >     process 6100
>     >     > [Mon Apr 03 23:10:01 2006] [notice] Child 6100: Child
>     process is
>     >     running
>     >     > [Mon Apr 03 23:10:02 2006] [notice] Child 4472: Released the
>     >     start mutex
>     >     > [Mon Apr 03 23:10:02 2006] [notice] Child 6100: Acquired the
>     >     start mutex.
>     >     > [Mon Apr 03 23:10:02 2006] [notice] Child 6100: Starting
>     250 worker
>     >     > threads.
>     >     > [Mon Apr 03 23:10:03 2006] [notice] Child 4472: Waiting
>     for 250
>     >     worker
>     >     > threads to exit.
>     >     > [Mon Apr 03 23:10:03 2006] [notice] Child 4472: All worker
>     threads
>     >     > have exited.
>     >     > [Mon Apr 03 23:10:03 2006] [notice] Child 4472: Child
>     process is
>     >     exiting
>     >     > [Mon Apr 03 23:10:21 2006] [notice] Parent: Received restart
>     >     signal --
>     >     > Restarting the server.
>     >     > [Mon Apr 03 23:10:21 2006] [notice] Child 6100: Exit event
>     >     signaled.
>     >     > Child process is ending.
>     >     > [Mon Apr 03 23:10:21 2006] [notice] Apache/2.0.55 (Win32)
>     configured
>     >     > -- resuming normal operations
>     >     > [Mon Apr 03 23:10:22 2006] [notice] Server built: Oct  9 2005
>     >     19:16:56
>     >     >
>     >     >
>     >     > On 4/4/06, *Larry Flathmann* < marketing@elrancho.com.mx
>     <mailto:marketing@elrancho.com.mx>
>     >     <mailto:marketing@elrancho.com.mx
>     <mailto:marketing@elrancho.com.mx>>
>     >     > <mailto: marketing@elrancho.com.mx
>     <mailto:marketing@elrancho.com.mx>
>     >     <mailto:marketing@elrancho.com.mx
>     <mailto:marketing@elrancho.com.mx>> >> wrote:
>     >     >
>     >     >     What do the error logs (in the Program Files/Apache...
>     /logs
>     >     >     folder) say?
>     >     >
>     >     >     BTW, don't worry! You are going to get Apache to work.
>     >     Little glitches
>     >     >     like this always get resolved! :)
>     >     >
>     >     >     Paul wrote:
>     >     >     > Greetings all
>     >     >     >
>     >     >     > Newbie alert!  I am new to this list and new to
>     apache, so
>     >     please
>     >     >     > forgive me if my understandings of the protocols aren't
>     >     100% yet
>     >     >     >
>     >     >     > I also did not find a dedicated list for win32 so I have
>     >     assumed
>     >     >     its
>     >     >     > the same list.
>     >     >     >
>     >     >     > please correct me if I am wrong
>     >     >     >
>     >     >     >
>     >     >     > I have a problem that I seriously cannot pinpoint.
>     >     >     >
>     >     >     > I do a bit of development on my local box and use
>     apache (of
>     >     >     course)
>     >     >     > as my web server
>     >     >     > I have installed apache quite a few times before and
>     know
>     >     how to
>     >     >     > change the document root to another localtion ( ie
>     D:\wed
>     >     ) etc
>     >     >     >
>     >     >     > Now I recently reinstalled windows from scratch and
>     am now
>     >     in the
>     >     >     > process of reinstalling apache. Trying to.
>     >     >     >
>     >     >     > I install it, open a web broswer, type localhost and
>     i get the
>     >     >     default
>     >     >     > page
>     >     >     >
>     >     >     > i edit the httpd.conf file and change the document
>     root from
>     >     >     > DocumentRoot "C:/Program Files/Apache
>     Group/Apache2/htdocs"
>     >     >     >
>     >     >     > to
>     >     >     >
>     >     >     > DocumentRoot "D:/web"
>     >     >     >
>     >     >     > Which is where my web root sits
>     >     >     >
>     >     >     > I also edit
>     >     >     >
>     >     >     > # This should be changed to whatever you set
>     DocumentRoot to.
>     >     >     > #
>     >     >     > <Directory "C:/Program Files/Apache
>     Group/Apache2/htdocs">
>     >     >     >  to
>     >     >     > <Directory "D:/web">
>     >     >     >
>     >     >     > and save the config and restart the server
>     >     >     >
>     >     >     > The minute I restart the server and hit localhost in my
>     >     browser , it
>     >     >     > hangs and searches for localhost and never finds it
>     >     >     >
>     >     >     > I have tried changing the config back to its original
>     >     state to
>     >     >     test it
>     >     >     > again, restarting the server service all the time and
>     >     still no joy.
>     >     >     >
>     >     >     > I use the apache monitor to restart the service
>     >     >     >
>     >     >     > NO joy
>     >     >     >
>     >     >     > its no proxy settings or anything of the sort as I
>     do not
>     >     >     have  any proxy
>     >     >     >
>     >     >     > however when I go into windows services and restart the
>     >     service from
>     >     >     > there and not the apache services monitor it seems
>     to work,
>     >     >     however I
>     >     >     > am still testing this
>     >     >     >
>     >     >     > I have reinstalled apache over and over again
>     removed it,
>     >     >     deleted all
>     >     >     > remaining files, downloaded a new copy of the win32
>     installer
>     >     >     > installed again and still the same problem
>     >     >     >
>     >     >     > I am not sure if its some funky setting on this box
>     or if
>     >     the apache
>     >     >     > monitor is wonky or if I am just forced to suffer
>     for my sins
>     >     >     now and
>     >     >     > cruise on through the pearly gates at a later stage
>     in my
>     >     life.
>     >     >     >
>     >     >     > Any idea?
>     >     >     >
>     >     >     > please?
>     >     >     >
>     >     >     >
>     >     >     >
>     >     >
>     >     >
>     >    
>     ---------------------------------------------------------------------
>     >     >     The official User-To-User support forum of the Apache HTTP
>     >     Server
>     >     >     Project.
>     >     >     See <URL:http://httpd.apache.org/userslist.html
>     <http://httpd.apache.org/userslist.html>> for more info.
>     >     >     To unsubscribe, e-mail:
>     users-unsubscribe@httpd.apache.org
>     <mailto:users-unsubscribe@httpd.apache.org>
>     >     <mailto: users-unsubscribe@httpd.apache.org
>     <mailto:users-unsubscribe@httpd.apache.org>>
>     >     >     <mailto:users-unsubscribe@httpd.apache.org
>     <mailto:users-unsubscribe@httpd.apache.org>
>     >     <mailto: users-unsubscribe@httpd.apache.org
>     <mailto:users-unsubscribe@httpd.apache.org>>>
>     >     >        "   from the digest:
>     >     users-digest-unsubscribe@httpd.apache.org
>     <mailto:users-digest-unsubscribe@httpd.apache.org>
>     >     <mailto: users-digest-unsubscribe@httpd.apache.org
>     <mailto:users-digest-unsubscribe@httpd.apache.org>>
>     >     >     <mailto:users-digest-unsubscribe@httpd.apache.org
>     <mailto:users-digest-unsubscribe@httpd.apache.org>
>     >     <mailto:users-digest-unsubscribe@httpd.apache.org
>     <mailto:users-digest-unsubscribe@httpd.apache.org>>>
>     >     >     For additional commands, e-mail:
>     users-help@httpd.apache.org <mailto:users-help@httpd.apache.org>
>     >     <mailto:users-help@httpd.apache.org
>     <mailto:users-help@httpd.apache.org>>
>     >     >     <mailto:users-help@httpd.apache.org
>     <mailto:users-help@httpd.apache.org>
>     >     <mailto:users-help@httpd.apache.org
>     <mailto:users-help@httpd.apache.org>>>
>     >     >
>     >     >
>     >
>     >    
>     ---------------------------------------------------------------------
>     >     The official User-To-User support forum of the Apache HTTP
>     Server
>     >     Project.
>     >     See <URL:http://httpd.apache.org/userslist.html> for more info.
>     >     To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>     <mailto:users-unsubscribe@httpd.apache.org>
>     >     <mailto:users-unsubscribe@httpd.apache.org
>     <mailto:users-unsubscribe@httpd.apache.org>>
>     >        "   from the digest:
>     users-digest-unsubscribe@httpd.apache.org
>     <mailto:users-digest-unsubscribe@httpd.apache.org>
>     >     <mailto: users-digest-unsubscribe@httpd.apache.org
>     <mailto:users-digest-unsubscribe@httpd.apache.org>>
>     >     For additional commands, e-mail: users-help@httpd.apache.org
>     <mailto:users-help@httpd.apache.org>
>     >     <mailto: users-help@httpd.apache.org
>     <mailto:users-help@httpd.apache.org>>
>     >
>     >
>
>     ---------------------------------------------------------------------
>     The official User-To-User support forum of the Apache HTTP Server
>     Project.
>     See <URL: http://httpd.apache.org/userslist.html> for more info.
>     To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>     <mailto:users-unsubscribe@httpd.apache.org>
>        "   from the digest: users-digest-unsubscribe@httpd.apache.org
>     <mailto:users-digest-unsubscribe@httpd.apache.org>
>     For additional commands, e-mail: users-help@httpd.apache.org
>     <mailto:users-help@httpd.apache.org>
>
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message