httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Evan Platt" <e...@espphotography.com>
Subject Re: [users@httpd] Unable to access apache through my IP
Date Tue, 18 Apr 2006 20:51:44 GMT
On Tue, April 18, 2006 1:44 pm, Cameron | Boomba wrote:
> Hi there.
> Does anyone know of any common problems with setting up apache to work
> through an IP? It works fine through localhost, but not through my IP.
>
> I can send anyone my httpd.conf if they want to see it, but I was just
> looking to see if there was any common causes for it. My router may be
> blocking it, but im not sure. What can I do to check and fix this?

by IP, do you mean public or private?

Are you behind a router providing NAT?

If I understand how it was explained to me, if say your NAT address is
192.168.1.3 and your public IP is 123.123.123.123, when you go to
123.123.123.123, it isn't going to your router, so it doesn't know where
to go. Like for me, I have www.mydomain.com , which works from the
outside, but on my local machine, I had to set up a alias entry in my
hosts file for www.mydomain.com to go to 192.168.1.X - I'm guessing it's
the same for your public IP.

Hope this makes sense


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message