httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nico Berg" <nb...@gandalf.name>
Subject [users@httpd] Webdav security fails
Date Tue, 04 Apr 2006 13:21:22 GMT
Hi there,

 

The error from my error_log file:

[Tue Apr  4 02:59:05 2006] [crit] [client 213.84.46.144] configuration
error:  couldn't check user.  No user file?: /

 

The part from httpd.conf that it's all about:

BrowserMatch "Microsoft Data Acces Internet Publishing Provider"
redirect-carefully

 

<VirtualHost webdav.gandalf.name>

DocumentRoot "/srv/webdav.gandalf.name"

ServerName webdav.gandalf.name

<Directory "/srv/webdav.gandalf.name">

    DAV On

AuthType Digest

AuthUserFile /etc/apache/.htaccess-dav

require valid-user

AuthName "nico"

</Directory>

</VirtualHost>

 

Output from httpd -V:

root@gandalf:/etc/apache# httpd -V

Server version: Apache/1.3.31 (Unix)

Server built:   Jun  1 2004 13:53:53

Server's Module Magic Number: 19990320:16

Server compiled with....

 -D EAPI

 -D HAVE_MMAP

 -D HAVE_SHMGET

 -D USE_SHMGET_SCOREBOARD

 -D USE_MMAP_FILES

 -D HAVE_FCNTL_SERIALIZED_ACCEPT

 -D HAVE_SYSVSEM_SERIALIZED_ACCEPT

 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT

 -D DYNAMIC_MODULE_LIMIT=64

 -D HARD_SERVER_LIMIT=256

 -D HTTPD_ROOT="/usr"

 -D SUEXEC_BIN="/usr/sbin/suexec"

 -D DEFAULT_PIDLOG="/var/run/httpd.pid"

 -D DEFAULT_SCOREBOARD="/var/run/httpd.scoreboard"

 -D DEFAULT_LOCKFILE="/var/run/httpd.lock"

 -D DEFAULT_ERRORLOG="/var/log/apache/error_log"

 -D TYPES_CONFIG_FILE="/etc/apache/mime.types"

 -D SERVER_CONFIG_FILE="/etc/apache/httpd.conf"

 -D ACCESS_CONFIG_FILE="/etc/apache/access.conf"

 -D RESOURCE_CONFIG_FILE="/etc/apache/srm.conf"

 

I am using:

Slackware 10.1

Linux 2.4.26

 

 

I found it strang that I have giving the line "AuthUserFile
/etc/apache/.htaccess-dav" to httpd.conf and the error say can't find file
at "/".

I have made .htaccess-dav with htpasswd -c /etc/apache/.htaccess-dav
username.

The webdavmodule is working, if I comment my securityline out then webdav is
working like a baby.

What has gone wrong here?

 

Greetings, Nico Berg


Mime
View raw message