httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Kosick <bkos...@mxlogic.com>
Subject [users@httpd] Re: Apache 2.2.0 and mod_authnz_ldap
Date Fri, 14 Apr 2006 19:55:19 GMT
Never mind...  I figured it out.

I was missing a flag:  --enable-ldap

./configure
--prefix=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build
--bindir=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build/bin.Linux
--libdir=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build/lib.Linux
--sbindir=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build/sbin.Linux
--libexec=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build/libexec.Linux
--with-ssl=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/openssl/build
--with-mpm=prefork 
--enable-static-support
--enable-ssl=static
--enable-v4-mapped
--with-ldap
--enable-ldap
--enable-authnz-ldap
--with-ldap-sdk=openldap
--enable-dbd
--enable-authn-dbd

I had originally had the --enable-ldap in there, but the makefile
complained that apxs needed --with-ldap, so I changed it over to
--with-ldap, and everything compiled.  I think that there should be a
check in the makefile similar to the one with --with-ldap for
--enable-ldap, as it's needed when you enable the mod_authnz_ldap.

Thanks,
Brian


On Fri, 2006-04-14 at 11:45 -0600, Brian Kosick wrote:
> Hi All,
> 
> I'm trying to get mod_authnz_ldap working statically compiled in, and I
> cannot seem to get it working.   Whenever I try to start up apache I get
> the following error.
> 
> [Fri Apr 14 11:36:41 2006] [error] Module mod_ldap missing. Mod_ldap
> (aka. util_ldap) must be loaded in order for mod_auth_ldap to function
> properly
> Configuration Failed
> 
> Here's my configure
> ./configure
> --prefix=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build
> --bindir=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build/bin.Linux --libdir=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build/lib.Linux
--sbindir=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build/sbin.Linux --libexec=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/apache/build/libexec.Linux
--with-ssl=/var/build/bkosick/edg-cozumel/Build/edg/edg-build/openssl/build --with-mpm=prefork
--enable-static-support --enable-ssl=static --enable-v4-mapped --with-ldap --enable-authnz-ldap
--with-ldap-sdk=openldap --enable-dbd --enable-authn-dbd
> 
> My httpd.conf file originally did not have a IfModule line for ldap, I
> tried adding:
> 
> <IfModule util_ldap.c>
>  <IfModule mod_authnz_ldap.c>
>  </IfModule>
> </IfModule>
>  
> It made no difference, and I got the same error.
> 
> Here the output from httpd -l
> 
> ./httpd -l
> Compiled in modules:
>   core.c
>   mod_authn_file.c
>   mod_authn_dbd.c
>   mod_authn_default.c
>   mod_authz_host.c
>   mod_authz_groupfile.c
>   mod_authz_user.c
>   mod_authnz_ldap.c
>   mod_authz_default.c
>   mod_auth_basic.c
>   mod_dbd.c
>   mod_include.c
>   mod_filter.c
>   mod_log_config.c
>   mod_env.c
>   mod_setenvif.c
>   mod_ssl.c
>   prefork.c
>   http_core.c
>   mod_mime.c
>   mod_status.c
>   mod_autoindex.c
>   mod_asis.c
>   mod_cgi.c
>   mod_negotiation.c
>   mod_dir.c
>   mod_actions.c
>   mod_userdir.c
>   mod_alias.c
>   mod_so.c
> 
> Anyone have any idea what I am missing, any and all help would be
> appreciated.
> 
> Thanks,
> Brian
> 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message