httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amalan, S" <Sountharanayaga.Ama...@comverse.com>
Subject RE: [users@httpd] making Apache work with WebLogic
Date Tue, 28 Mar 2006 20:29:53 GMT
Alex,

Just FYI: I found the following in the file config.log (this was in the
directory where I had downloaded the application and not in the
installation directory):

configure:14003: checking whether to enable mod_suexec
configure:14055: result: no

Can you interpret this for me?

I ran your command:  truss -fael -tall -vall -xall -rall -wall -o output
apachectl start

And the output file contained:

20672/1:        read(9, 0x000DEFE8, 4096)                       = 0
20672/1:        close(9)                                        = 0
20672/1:        open(0x0010D578, 02401, 0644)                   Err#13
EACCES
20672/1:             0x0010D578: "wlproxy_lock"
20672/1:        write(7, 0xFFBED670, 100)                       = 100
20672/1:           [ T u e   M a r   2 8   1 3 : 2 3 : 1 7   2 0 0 6 ]
[ c r i t
20672/1:           ]   ( 1 3 ) P e r m i s s i o n   d e n i e d :   m o
d _ w e b
20672/1:           l o g i c :   P a r e n t   c o u l d   n o t   c r e
a t e   l
20672/1:           o c k\n
20672/1:        write(2, 0xFFBED750, 21)                        = 21
20672/1:           C o n f i g u r a t i o n   F a i l e d\n

This is essentially the same as what I saw in the error_log sent to you
earlier - so what do you gather from this?

Thanks.
Amalan

-----Original Message-----
From: Alexander Lazic [mailto:al-httpdusers@none.at] 
Sent: Tuesday, March 28, 2006 3:12 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] making Apache work with WebLogic

Amalan,

On Die 28.03.2006 12:17, Amalan, S wrote:
>
>I don't see the file "suexec" under bin.  Hmm..what happened here?

I don't know.

>The error_log as nothing other than the following repeating each time I
>try to run Apache (timestamp changes of course):

Sure ;-)

>[Tue Mar 28 11:32:47 2006] [crit] (13)Permission denied: mod_weblogic:
>Parent could not create lock Configuration Failed

Ok please try the following:

truss -fael -tall -vall -xall -rall -wall -o output $APACHECTL_START

then look into the output and search for PERM or

 P e r m i

The spaces are important!

Regards

Alex

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message