httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amalan, S" <Sountharanayaga.Ama...@comverse.com>
Subject RE: [users@httpd] making Apache work with WebLogic
Date Tue, 28 Mar 2006 18:54:30 GMT
Alex,

My system has worked so far with binaries doing dynamic linking all the
time.  And now I am wondering how they could have worked :-)

env | grep LD_LIBRARY_PATH

LD_LIBRARY_PATH=/opt/SUNWspro/lib:/usr/openwin/lib:/sybase/sybase11/lib:
/opt/IXImd12s/lib:/lib/cmplrs/cob/coblib:/usr/dt/lib

And yes, I do see libc.so.1 under /lib on my machine too, so I guess I
need to include /lib in my LD_LIBRARY_PATH?  But, who knows what else
needs to be in there - never had problems until I ran Apache with
WebLogic plug-in. In other words, I think BEA should mention this
setting and the necessary inclusions. You think not?

After inclusion in the env variable, I found more files missing and
after successive searches, I had to include:

/lib
/local/lib
/usr/lib

So, now:

LD_LIBRARY_PATH=/usr/lib:/local/lib:/lib:/opt/SUNWspro/lib:/usr/openwin/
lib:/sybase/sybase11/lib:/opt/IXImd12s/lib:/lib/cmplrs/cob/coblib:/usr/d
t/lib

And now, the truss output complains about more:

open("/var/ld/ld.config", O_RDONLY)             Err#2 ENOENT

I can't find this file anywhere on my machine.

Further:
stat("/local/lib/libgen.so.1", 0xFFBEF0AC)      Err#2 ENOENT
stat("/lib/libgen.so.1", 0xFFBEF0AC)            = 0
open("/lib/libgen.so.1", O_RDONLY)              = 3

This is not an error that matters, is it?  As long as it found it on the
subsequent location, I presume it is fine?  There are more such
occurrences - that is why I ask for confirmation.

What is this:
stat("/users/denver/amas01/apache2.0/apache-2.0.55-install_dir/bin/suexe
c", 0xFFBEF5A8) Err#2 ENOENT
open("/etc/netconfig", O_RDONLY)                = 3
fstat64(3, 0xFFBEEAC0)                          = 0

is it not finding an executable under one of the subdirectories of the
installation dir?

Also, I find one more error:
open("/users/denver/amas01/apache2.0/apache-2.0.55-install_dir/logs/http
d.pid", O_RDONLY) Err#2 ENOENT
setsockopt(3, 65535, 4, 0xFFBEF58C, 4, 1)       = 0

I guess this is expected, since the Apache server did not start?

Appreciate your help.

Amalan

-----Original Message-----
From: Alexander Lazic [mailto:al-httpdusers@none.at] 
Sent: Tuesday, March 28, 2006 1:14 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] making Apache work with WebLogic

Hi,

On Die 28.03.2006 11:06, Amalan, S wrote:
>
>OS = SunOS 5.8
>
>Great idea re: truss.  I ran it and found the following in the output:
>
>stat("/opt/SUNWspro/lib/libc.so.1", 0xFFBEF0BC) Err#2 ENOENT
>stat("/usr/openwin/lib/libc.so.1", 0xFFBEF0BC)  Err#2 ENOENT
>stat("/sybase/sybase11/lib/libc.so.1", 0xFFBEF0BC) Err#2 ENOENT  <- I
>don't need Sybase, so I don't know why it was looking for this
>lib
>stat("/opt/IXImd12s/lib/libc.so.1", 0xFFBEF0BC) Err#2 ENOENT
>stat("/lib/cmplrs/cob/coblib/libc.so.1", 0xFFBEF0BC) Err#2 ENOENT
>
>I guess the missing libs are associated with C, but didn't see any
>specific requirements from BEA regarding C libs to get their plug-in to
>work.

Hm what is in your LD_LIBRARY_PATH, because?

ls -la /lib/libc.so.1
... 1158072 Jul 19  2005 /lib/libc.so.1

on:

SunOS 5.8  sun4u sparc

>I have started the ball rolling to get these libs installed (the dirs
>exist, just these libs from the output above are missing), and once it
>is done, I will try running Apache again.

Aehm when you don't have a libc how can you system work?!  Are all your
binaries static ;-)?

regards

Alex

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message