httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bankar, Swati" <SBan...@verisign.com>
Subject [users@httpd] Issue during Apache 2.0 module development
Date Thu, 16 Mar 2006 07:24:26 GMT
Hi,

We have written a dynamic module for Apache2.0.54 on RH Linux 3.0.
 
The basic function of this module is authentication of the user before giving access to the
protected resources.
 

Currently we have made a a directory "/protected" as protected resource. The module provides
access to this resource only if the user is a valid resource.
 

Also, requests for all the sites hosted on the apache web server go through this dynamic module.
If the user tries to access protected resource, the module calls an internal handler which
does the further processing.
 

In case of normal url's (one which is not protected), the request goes to module which in
turn calls a handler. This handler checks if the url being accessed is protected or not. If
the url is not protected, the handler returns OK status.
 

PROBLEM:


The problem that we are facing is that the pages being accessed are not getting rendered properly.We
just get a blank page.

Eg: If we access a non-protected resource, we are not shown the page that we had requested.
Instead we get a blank page.

 

Similarly, if we try to access a protected resource also we get a blank page. Instead of the
actual page.

 

Following are the values in the request::::>

 

-- req->the_request value is::> GET /protected/TransSigningMS.htm HTTP/1.1

-- req->header_only value is::> 0

-- req->protocol value is::> HTTP/1.1

-- req->status value is::> 200

-- req->status_line value is::> (null)

-- req->read_body value is::> 0

-- req->content_type value is::> text/html

-- req->handler value is::> pta-send

-- req->uri value is::> /protected/TransSigningMS.htm

-- req->filename value is::> /var/www/html/protected/TransSigningMS.htm

-- req->args value is::> (null)

-- req->headers_out=[]

-- req->notes=[ap-mime-exceptions-list="@úLµ^D"]

 

Here, the values in ap-mime-exceptions-list seems to be corrupt.

Can this be an issue?


Any help in this regard will be very helpful.


Eagerly awaiting replies.

Thanks

Warm Regards,
Swati Bankar.

Verisign ODC, Pune
Direct # 91-20-22973085

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message