httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Mehringer <davemehrin...@yahoo.com>
Subject Re: [users@httpd] issues with apache for windows
Date Sun, 26 Mar 2006 21:26:10 GMT
Thanks for the useful suggeston. The meesage indicated there was some issue with the permissions
on the conf file. I reset the permissions and the server now starts.
  Dave
  

Emmanuel E <emmanuel.e@gmx.net> wrote:
          what does the event log in windows say? Start->Control Panel->Administrative
tools->Event Viewer->Application
  See if there are any messages from Apache Service.
    ----- Original Message ----- 
  From: Dave Mehringer 
  To: users@httpd.apache.org 
  Sent: Sunday, March 26, 2006 9:39 PM
  Subject: [users@httpd] issues with apache for windows
  

  I had been running the 2.0.54 version of Apache on Windows XP Pro for several months without
any major issues. The server is configured to start as a windows service at boot time. 
   
  Recently, I was making changes the the conf file which of course required restarts of the
server for the changes to take effect. The conf file is valid; I ran the server with the -t
option.  However, the server will not start now on boot or from the normal start controls
in the apache monitor or from the apache secton of the Start->All Programs menu.. There
are no messages of any kind written to the error log when Apache tries to start in this manner.
When trying to start it from the windows services GUI, I get a message that the server-specific
error code is 1.
   
  I've uninstalled 2.0.54 and installed 2.0.55, but have the same results.
   
  The server will start if I start it manaully fr om a Windows Command Prompt terminal using

   
  "C:\Program Files\Apache Group\Apache2\bin\Apache.exe" -w -n "Apache2" -k start
   
  However, this will not do as a long term solution.
   
  In the past, I have had issues when restarting the server, but this has always been resolved
by a reboot (again not a great solution, but something I could live with since I don't need
to interactively restart the server very much). However, rebooting does not resolve the issue
now.
   
  Any ideas?
   
    
---------------------------------
  New Yahoo! Messenger with Voice. Call regular phones from your PC and save big.  


		
---------------------------------
New Yahoo! Messenger with Voice. Call regular phones from your PC and save big.
Mime
View raw message