httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Apache will not start
Date Tue, 21 Feb 2006 19:04:54 GMT
On 2/21/06, Mark McCulligh <mmcculli@visualtech.ca> wrote:
> Hi Group,
>
> I have a Ferdora Core 4 system with Apache 2.0.54 installed from rpm and
> it is work fine.  I then installed PostgreSQL 8.1.3, MySQL 4.1.18 and
> PHP 4.4.2 from their tarballs.   Everything compiled without any errors
> that I saw.  When I add LoadModule PHP4 line to httpd.conf apache will
> not start. If I do a configtest the syntax is ok, but get the message
> FAILED when I run start.  There is no messages in the error log file and
> it displays no error messages to me.  Just says failed.
>
> How to I figure out that the problem is without any error messages or is
> there another log file I can look for an error message in.

Try starting httpd or apachectl directly rather than through the redhat scripts.

But I'd give at least 3:1 odds that your problem is improper SELinux
configuration on your new modules, meaning that the SELinux-restricted
httpd cannot load them or one of their dependencies.  I don't have the
recipe for the solution, but check the links under "Permission Denied"
here:
http://httpd.apache.org/docs/2.2/faq/error.html#error.permissiondenied

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message