httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] DirectoryIndex in *.conf WAS 403 Forbidden Error
Date Tue, 07 Feb 2006 21:21:20 GMT
On 2/7/06, Jonathan S. Abrams <j.abrams@nutmegaudiopost.com> wrote:

>        "[Tue Feb 07 16:00:14 2006] [error] [client 198.65.202.94]
> Directory in\
>         dex forbidden by rule: /Library/WebServer/new_FTP-Server/test/

There is the error log entry that you kept promising us didn't exist. 
You must be looking in the wrong error log.

The entry tells us that you do not have "Options Indexes" set on the
directory in question.

Looking at the VirtualHost config you posted above, I note that it
looks like a name-based virtual host, but there is no ServerName
directive.  So I suspect that this <VirtualHost> block is not being
used at all.  This would explain why the configurations contained in
it have no effect, and also why the errors are getting sent to a
different log file.

So you need to start by figuring out which <VirtualHost> block (if
any) is actually serving the request, and adjust the configuration in
that block.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message