httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan van den Berg" <jan.vandenb...@isp.solcon.nl>
Subject [users@httpd] CGI script with & without dash in name on Apache 2.0.55
Date Wed, 15 Feb 2006 10:30:06 GMT
I have a very strange problem.

I have written a cgi script that has an image file (counter) as output.
I run it like this:

www.site.com/cgi-bin/nph?width=5&link=http://www.hitsite.com

This runs perfectly. However when I rename the program from 'nph' ->
'nph-hits' (same UID/GID and system rights) and I run it my browser asks
what to do with the file ("octet-stream save as/open with")?!?! So like
this:

www.site.com/cgi-bin/nph-hits?width=5&link=http://www.hitsite.com

The content of the script and all the rights are exactly the same?!
However Apache seems to be handling it differently. I am running Apache
2.0.55 with just plain perl 5.8.4 (no mod_perl).

This is very strange to say the least. I can rename the file to anything
as long as there is no dash in there. So that's probably causing the
problem but I can't find any information on this. Who has a solution for
this?

(The program needs to have a dash because of a migration from an older
tool with a dash in the name).

Regards,

Jan

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message