httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dotan Cohen" <dotanco...@gmail.com>
Subject [users@httpd] Starting / Stoping Apache
Date Sun, 19 Feb 2006 16:44:56 GMT
I have installed apache on Kubuntu 5.10 and I cannot seem to start/
stop the service.

I initally installed apache via "apt-get install apache". I then read
that for apache 2.x I must do "apt-get install apache2" so I did that.
When I typed 127.0.0.1 into my browser I got the apache directory
listing.

I then did "apt-get remove apache" to remove apache 1.x, but as soon
as I did, I was no longer getting and response form 127.0.0.1 so I did
"apt-get install apache2" again. No luck. I then did "apt-get install
apache" and I was once again getting the page at 127.0.0.1

Now, I want to start and stop the service. I tried "service httpd
stop" but I got:
root@ety:~# service httpd stop
-su: service: command not found

I then tried some other things that I found though google:
root@ety:~# /usr/sbin/apache2ctl stop
httpd (no pid file) not running
root@ety:~# apache2ctl stop
httpd (no pid file) not running
root@ety:~# /etc/init.d/apache2 stop
 * Stopping web server (Apache2)...

But, it is _still_ serving pages on 127.0.0.1! What must I do to stop
and start the server?!?

Also, what must I do to remove apache 1.x and just have apache 2.x?

Thanks in advance.

Dotan Cohen
http://technology-sleuth.com/
Mime
View raw message