httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Evan Platt" <e...@espphotography.com>
Subject [users@httpd] Images / files partially loading?
Date Thu, 23 Feb 2006 01:05:35 GMT
Here's the situation, I've looked in the faq, not sure what wording to
use, so that could partially be my problem... One solution I found was to
enable Enable SendFile Off, that didn't help..

Here's the setup:
6.0 mbps/600k DSL (6 megs down, 600 k upstream). 2 computers on
network: Dell PC, and Mac G4. Mac G4 is running apache.2.0.52.

Attempting to retrieve any large file (well over 65536 bytes), it
stalls and retries every 65536 bytes:



C:\>wget http://www.espphotography.com/buttplug.mp3
--16:24:50--  http://www.espphotography.com:80/buttplug.mp3
           => `buttplug.mp3'
Connecting to www.espphotography.com:80... connected!
HTTP request sent, awaiting response... 200 OK
Length: 1,642,160 [audio/mpeg]

    0K -> .......... .......... .......... .......... .......... [ 3%]
   50K -> .......... ....                                        [ 3%]

16:24:51 (64.00 KB/s) - Connection closed at byte 65536. Retrying.

--16:24:51--  http://www.espphotography.com:80/buttplug.mp3
  (try: 2) => `buttplug.mp3'
Connecting to www.espphotography.com:80... connected!
HTTP request sent, awaiting response... 206 Partial Content
Length: 1,642,160 (1,576,624 to go) [audio/mpeg]

          [ skipping 50K ]
   50K -> ,,,,,,,,,, ,,,,...... .......... .......... .......... [ 6%]
  100K -> .......... .......... ........                         [ 7%]

16:24:52 (64.00 KB/s) - Connection closed at byte 131072. Retrying.

--16:24:52--  http://www.espphotography.com:80/buttplug.mp3
  (try: 3) => `buttplug.mp3'
Connecting to www.espphotography.com:80... connected!
HTTP request sent, awaiting response... 206 Partial Content
Length: 1,642,160 (1,511,088 to go) [audio/mpeg]

          [ skipping 100K ]
  100K -> ,,,,,,,,,, ,,,,,,,,,, ,,,,,,,,.. .......... .......... [ 9%]
  150K -> .......... .......... .......... .......... .......... [
12%]
  200K ->                                                        [
12%]

16:24:54 (72.00 KB/s) - Connection closed at byte 204800. Retrying.
And so on.

Getting a file from the PC (running  IIS, but that may change) is
fine.

Getting a file from the mac sitting at the PC (i.e.
http://192.168....) has similiar results - the retry size is a little
larger.

But from outisde the intranet, it's constantly 65536 bytes.

Any suggestions appreciated. If I'm leaving out any details, please
ask.

Thanks.

Evan


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message