httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [users@httpd] Virtual Hosts on 127.0.0.*
Date Fri, 10 Feb 2006 21:03:17 GMT
Joshua Slive wrote:
> On 2/10/06, Diona Kidd <dkidd@modernflow.com> wrote:
> 
>>(98)Address already in use: make_sock: could not bind to address
>>127.0.0.10:80
>>no listening sockets available, shutting down
>>Unable to open logs
>>
>>What am I missing? I'm running Debian 3.1, no iptable rules configured, no
>>firewall. Does anyone else have a setup like this?

> Check your front-end instance of apache.  It probably has something like
> Listen 80
> Listen 443
> 
> These will grab all IP addresses on the machine, including the
> loopback.  Change those to grab only the external addresses.

FYI, for Win32 XP SP2 users, there is a hotfix from Microsoft if you are trying
to using 127.0.0.2 - 127.255.255.255 - because Microsoft had the silly idea
that loopback addresses other than 127.0.0.1 were bad, and they broke this
rather standard behavior in that service pack.

Bill

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message