httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [users@httpd] Win32 Apahce 2.0.55 mod_ssl & Apache::ASP
Date Wed, 01 Feb 2006 19:28:38 GMT
Jason J. Czerak wrote:
> I'm benchmarking one of our sites. After some debugging I have found 
> that when the site has ssl enabled, performance starts to degrade very 
> rapidly, even to the point of rendering the server useless after 20 
> concurrent users.  The servers CPU resources are 2% at this point when 
> Apache fails.  So it's not a hardware limitation. The Same tests yields 
> very good results without SSL
> 
> The application is an Apache::ASP (perl) based application

I suspect from your post that this is the flaw.  Can you first try stressing
only static documents (e.g. /images/* etc) and see if this happens with modperl
still loaded; then try stressing static documents without loading modperl?

Finally, if modperl is indicated, you need to be aware that modperl is very
tightly coupled with the protocol filtering, and it's entirely possible that
there is a negative interaction there.  Please post your results.

Bill

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message