httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "noip" <n...@webhost66.com>
Subject [users@httpd] Apache 2.0/2.2 + Suexec + Mod_Frontpage help
Date Fri, 03 Feb 2006 15:05:08 GMT
Hello, 

Curently i'm running Apache 1.3.34 + Suexec with PHP_Suexec + Mod_Frontpage_Mirfak and
i have plans to upgrade to Apache version 2.0 or 2.2.
The problems is that i can't find a easy way to make Frontpage to work with Suexec for Apache
2 (i hate Frontpage but we have many clients that are using it).
The module that is provided from rtr.com doesn't works with Suexec Enabled with the newer
versions of Apache 2.0. Mod_Frontpage_Mirfak is for Apache 1.3 only. For Apache 1.3 i've tried
a simple patch that checks if the executable is the Frontpage binary and if it is - it is
executed without Suexec. The patch is very simple:

--- ./src/main/util_script.c.orig	Wed Apr  3 13:42:49 2002
+++ ./src/main/util_script.c	Wed Apr  3 13:47:30 2002
@@ -1182,6 +1182,7 @@
 #elif defined(NETWARE)
 #else
     if (ap_suexec_enabled
+	&& (strcmp(r->filename, "/usr/local/frontpage/version5.0/apache-fp/_vti_bin/fpexe"))
 	&& ((r->server->server_uid != ap_user_id)
 	    || (r->server->server_gid != ap_group_id)
 	    || (!strncmp("/~", r->uri, 2)))) {

Is there a patch that makes Frontpage to works with Suexec ? And if there is not, is it possible
something to be done like the patch that i've pasted above ? Or there is other solution ?


Thank You 
Iavor
 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message