httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mukarram Syed <>
Subject [users@httpd] Apache 1.3.34 make error:
Date Thu, 02 Feb 2006 01:33:15 GMT
I am installing Apache with mod_ssl and open_ssl 0.9.8a.

After compiling, I run "make" and I am getting the following error:

/libos.a ap/libap.a  lib/expat-lite/libexpat.a  -lsocket -lnsl -lpthread  -lssl -lcrypto
Undefined                       first referenced
 symbol                             in file
dlsym                               /opt/home/msyed/apache-build/apache-modssl.sephorakiosk.20060201/openssl-0.9.8a/libcrypto.a(dso_dlfcn.o)
 (symbol belongs to implicit dependency /usr/lib/
dlopen                              /opt/home/msyed/apache-build/apache-modssl.sephorakiosk.20060201/openssl-0.9.8a/libcrypto.a(dso_dlfcn.o)
 (symbol belongs to implicit dependency /usr/lib/
dlclose                             /opt/home/msyed/apache-build/apache-modssl.sephorakiosk.20060201/openssl-0.9.8a/libcrypto.a(dso_dlfcn.o)
 (symbol belongs to implicit dependency /usr/lib/
dlerror                             /opt/home/msyed/apache-build/apache-modssl.sephorakiosk.20060201/openssl-0.9.8a/libcrypto.a(dso_dlfcn.o)
 (symbol belongs to implicit dependency /usr/lib/
ld: fatal: Symbol referencing errors. No output written to httpd
collect2: ld returned 1 exit status
make[2]: *** [target_static] Error 1
make[2]: Leaving directory `/opt/home/msyed/apache-build/apache-modssl.sephorakiosk.20060201/apache_1.3.34/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/opt/home/msyed/apache-build/apache-modssl.sephorakiosk.20060201/apache_1.3.34'
make: *** [build] Error 2

There is a reference to this very same error in mailing list:

But I don't understand what the fix is?

Can someone look at it and explain it to me?

I would appreciate the response.


-Mukarram Syed.

Mukarram Syed
Bring words and photos together (easily) with
 PhotoMail  - it's free and works with Yahoo! Mail.
View raw message