httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nico De Ranter <n...@sonycom.com>
Subject [users@httpd] sumbol multiple-defined when compiling httpd 2.2.0 on Solaris 8
Date Fri, 03 Feb 2006 14:52:37 GMT

Hi,

I'm trying to compile httpd 2.2.0 on Solaris 8.  When I do 'make
install' it stops with the following error messages:

===========================================================================
[..]
/usr/root/web/httpd-2.2.0/srclib/apr/libtool --silent --mode=link gcc -g
-O2 -pthreads
-L/usr/root/web/httpd-2.2.0/srclib/apr-util/xml/expat/lib
-L/openssl-0.9.8a/lib -R/openssl-0.9.8a/lib  -ldl -o ab -static ab.lo
-lm /usr/root/web/httpd-2.2.0/srclib/pcre/libpcre.la /usr/root/web/httpd-2.2.0/srclib/apr-util/libaprutil-1.la
/usr/root/web/httpd-2.2.0/srclib/apr-util/xml/expat/lib/libexpat.la /usr/root/web/httpd-2.2.0/srclib/apr/libapr-1.la
-lsendfile -lrt -lsocket -lnsl -lpthread -lssl -lcrypto
ld: fatal: symbol `SHA256_Transform' is multiply-defined:

(file /usr/root/web/httpd-2.2.0/srclib/apr/.libs/libapr-1.a(sha2.o)
type=FUNC; file /openssl-0.9.8a/lib/libcrypto.a(sha256.o) type=FUNC);
ld: fatal: symbol `SHA256_Init' is multiply-defined:

(file /usr/root/web/httpd-2.2.0/srclib/apr/.libs/libapr-1.a(sha2.o)
type=FUNC; file /openssl-0.9.8a/lib/libcrypto.a(sha256.o) type=FUNC);
ld: fatal: symbol `SHA256_Final' is multiply-defined:

(file /usr/root/web/httpd-2.2.0/srclib/apr/.libs/libapr-1.a(sha2.o)
type=FUNC; file /openssl-0.9.8a/lib/libcrypto.a(sha256.o) type=FUNC);
ld: fatal: symbol `SHA256_Update' is multiply-defined:

(file /usr/root/web/httpd-2.2.0/srclib/apr/.libs/libapr-1.a(sha2.o)
type=FUNC; file /openssl-0.9.8a/lib/libcrypto.a(sha256.o) type=FUNC);
ld: fatal: File processing errors. No output written to ab
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `ab'
Current working directory /usr/root/web/httpd-2.2.0/support
===========================================================================

Any idea how to fix this.

I used the following parameters to configure it:

export ZLIBVER=1.2.3
export SSLVER=0.9.8a
export HTTPDVER=2.2.0
./configure --prefix=${PREFIX}/httpd-${HTTPDVER} \
            --with-z=${PREFIX}/zlib-${ZLIBVER}/lib/libz.so \
            --with-ssl=${PREFIX}/openssl-${SSLVER} \
            --enable-ssl \
            --enable-static-support \
            --enable-http \
            --enable-dav \
            --enable-dav-fs \
            --enable-dav-lock \
            --enable-rewrite \
            --enable-so \
            --enable-mime-magic \
            --enable-expires \
            --enable-headers \
            --enable-usertrack \
            --enable-unique-id \
            --enable-auth-digest \
            --enable-cgi


Thanks in advance,

Nico

-- 
---------------------------------------------------------
 "It has been said that there are only two businesses that
  refer to customers as users: illegal drug trade and
               the computer industry."
---------------------------------------------------------
Nico De Ranter
Senior System Administrator
Sony Service Center (NSCE)
The Corporate Village, Da Vincilaan 7-D1
B-1935 Zaventem, Belgium
Telephone: +32 (0)2 700 86 41 Fax: +32 (0)2 700 86 22



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message