httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Mangin" <jon.man...@comcast.net>
Subject Re: [users@httpd] Symbol referencing errors (Solved)
Date Thu, 02 Feb 2006 16:12:23 GMT
> In compiling 2.0.55 on Solaris 8x86 I'm getting symbol
> referencing errors:
>
> Undefined                       first referenced
>  symbol                             in file
> ap_meets_conditions                 server/.libs/libmain.a(exports.o)
> ap_setup_client_block               server/.libs/libmain.a(exports.o)
> ap_byterange_filter                 server/.libs/libmain.a(exports.o)
> ap_mpm_run                          server/.libs/libmain.a(main.o)
> ld: fatal: Symbol referencing errors. No output written to .libs/httpd
> collect2: ld returned 1 exit status
> make[1]: *** [httpd] Error 1
> make[1]: Leaving directory
> `/export/home/jman/download/src/apache/httpd-2.0.55'
>
cat config.nice
#! /bin/sh
#
# Created by configure

CC="gcc"; export CC
CPPFLAGS="-I/export/home/jman/download/src/apache/httpd-2.0.55/include";
export CPPFLAGS
"./configure" \
"CC=gcc" \
"RM=/usr/bin/rm" \
"AWK=/usr/local/bin/awk" \
"CPPFLAGS=-I/export/home/jman/download/src/apache/httpd-2.0.55/include" \
"--prefix=/usr/local/apache3" \
"--enable-shared-mods=all" \
"$@"

RM definition ignored and needs adding to build/config_vars.mk

Make sure /usr/local/bin in $PATH before /usr/bin.

Thanks, guys.
Jon


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message