httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brenda Washington" <bwashing...@pnc.edu>
Subject [users@httpd] Apache directives
Date Fri, 27 Jan 2006 18:04:29 GMT
I upgraded my apache server from apache 1.3 with Openldap-2.0 and mod_ssl-2.0 to apache 2.0.
With openldap-2.0 and mod_ssl-2.0 running.  I configured the mod_auth_ldap directives AuthLDAPBindAsUser
and AuthLDAPcryptPasswords in the apache 1.3 httpd.conf file which worked great with my ldap
server and portal. These directives are no longer available for apache 2.0. What directive
in apache 2.0 can I replace the directives with that will work with my ldap server and portal?
I can connect to the ldap server, but the portal does not work. These are the mod_auth_ldap
directives I have in apache 1.3 httpd.conf file.  
<Directory "/path/to/cgi-bin/files">
AllowOverride None
order allow,deny
allow from all
AuthName 
AuthType Basic
AuthLDAPHosts 
AuthLDAPBindAsUser 
AuthLDAPBaseDN  
AuthLDAPUserKey 
AuthLDAPCryptPasswords 
require valid-user

These are the mod_auth_ldap directive for apache 2.0 in my ssl.config file. 
 
<Directory "/path/to/cgi-bin/files">
AllowOverride None
order allow,deny
allow from all
AuthName "Faculty"
AuthType Basic
AuthLDAPUrl ldap:// url
AuthLDAPRemoteUserIsDN on
require valid-user
</Directory>

 
 


Mime
View raw message