httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathy.Rix...@rrd.com
Subject Re: [users@httpd] Having trouble installing Apache 2.2.0 on SUSE LINUX version 9
Date Thu, 05 Jan 2006 15:50:00 GMT
Tried that yesterday, with the same results.  I really do think I have a
corrupted library, but don't quite know how to fix it.  For the record,
here is what I see when I enter /usr/lib/libex*

-rw-r--r--  1 root root 159982 2004-06-30 14:03 libexpat.a
-rwxr-xr-x  1 root root    706 2004-06-30 14:03 libexpat.la
lrwxrwxrwx  1 root root     17 2005-12-22 14:57 libexpat.so ->
libexpat.so.0.5.0
lrwxrwxrwx  1 root root     17 2005-12-22 14:57 libexpat.so.0 ->
libexpat.so.0.5.0
-rwxr-xr-x  1 root root 160096 2004-06-30 14:03 libexpat.so.0.5.0
lrwxrwxrwx  1 root root     17 2005-12-23 10:07 libexslt.so.0 ->
libexslt.so.0.8.2
-rwxr-xr-x  1 root root  67684 2005-10-27 08:24 libexslt.so.0.8.2


                                                                                         
                 
                      Lyndon Tiu                                                         
                 
                      <ltiu@alumni.sfu         To:      users@httpd.apache.org        
                    
                      .ca>                     cc:                                    
                    
                                               Subject: Re: [users@httpd] Having trouble installing
Apache 
                      01/05/2006 10:44         2.2.0 on SUSE  LINUX version 9            
                 
                      AM                                                                 
                 
                      Please respond                                                     
                 
                      to users                                                           
                 
                                                                                         
                 
                                                                                         
                 




Just curious, can you try compiling 2.0.55 instead and see what happens.

On Thu, 5 Jan 2006 10:32:24 -0500 users@httpd.apache.org wrote:
>
>
> I am trying to install Apache Server on a SUSE LINUX Version 9 machine.
> The machine is X86_64.
>
> OK, I admit that I am new at this, but I keep getting this same error.  I
> have tried just the configure and make, and even tried building the
> apr/apr-util.  I get this same issue on the regular make and also the
make
> for apr-util.  I think I have a corrupt /usr/lib/libexpat.so, but don't
> know what to do to get this corrected.
>
> I have looked in the archives and the documentation, but have not found
> this particular problem.  I would appreciate any help you all can give me
> on this one.
>
> Kathy
>
> /bin/sh /usr/local/apr-httpd//build-1/libtool --silent --mode=link  gcc
-g
> -O2 -pthread   -DHAVE_CONFIG_H -DLINUX=2 -D_REEN
> TRANT -D_GNU_SOURCE   -I/usr/local/src/httpd-2.2.0
/srclib/apr-util/include
> -I/usr/local/src/httpd-2.2.0/srclib/apr-util/inc
> lude/private  -I/usr/local/apr-httpd//include/apr-1    -version-info
2:2:2
> -o libaprutil-1.la -rpath /usr/local/apr-util
> /httpd//lib buckets/apr_buckets_alloc.lo buckets/apr_buckets_refcount.lo
> buckets/apr_buckets_socket.lo buckets/apr_buckets_
> file.lo buckets/apr_buckets_heap.lo buckets/apr_buckets.lo
> buckets/apr_brigade.lo buckets/apr_buckets_mmap.lo buckets/apr_b
> uckets_pipe.lo buckets/apr_buckets_eos.lo buckets/apr_buckets_pool.lo
> buckets/apr_buckets_simple.lo buckets/apr_buckets_flu
> sh.lo crypto/apr_sha1.lo crypto/apr_md4.lo crypto/apr_md5.lo
> crypto/getuuid.lo crypto/uuid.lo dbm/apr_dbm_ndbm.lo dbm/apr_d
> bm_sdbm.lo dbm/apr_dbm.lo dbm/apr_dbm_gdbm.lo dbm/apr_dbm_berkeleydb.lo
> dbm/sdbm/sdbm_hash.lo dbm/sdbm/sdbm_lock.lo dbm/sdb
> m/sdbm_pair.lo dbm/sdbm/sdbm.lo encoding/apr_base64.lo hooks/apr_hooks.lo
> ldap/apr_ldap_init.lo ldap/apr_ldap_url.lo ldap/a
> pr_ldap_option.lo misc/apr_reslist.lo misc/apr_rmm.lo misc/apu_version.lo
> misc/apr_queue.lo misc/apr_date.lo uri/apr_uri.lo
>  xml/apr_xml.lo strmatch/apr_strmatch.lo xlate/xlate.lo dbd/apr_dbd.lo
> dbd/apr_dbd_sqlite2.lo dbd/apr_dbd_sqlite3.lo dbd/ap
> r_dbd_pgsql.lo   -lrt -lcrypt  -lpthread -ldl  -lgdbm -ldb-4.2
> /usr/lib/libexpat.la /usr/local/apr-httpd//lib/libapr-1.la -
> lrt -lcrypt -lpthread -ldl
>
> /usr/lib/libexpat.so: could not read symbols: Invalid operation
> collect2: ld returned 1 exit status
> make[1]: *** [libaprutil-1.la] Error 1
> make[1]: Leaving directory `/usr/local/src/httpd-2.2.0/srclib/apr-util'
> make: *** [all-recursive] Error 1
>
> ------------------
> CONFIDENTIALITY NOTICE:  The information contained in this email message
is
> confidential and may be protected from disclosure.  Please be aware that
> any unauthorized use, printing, copying, disclosure or dissemination of
> this communication may be subject to legal restriction or sanction.  If
you
> think you have received this email message in error, please reply to
> sender.


--
Lyndon Tiu

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message