httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prepaid <prep...@gmail.com>
Subject [users@httpd] Compiling Apache 2.2.0 on Solaris 10 with mod_authnz_ldap support
Date Wed, 25 Jan 2006 19:41:55 GMT
Hello

So I am attempting to build apache with mod_authnz_ldap on Solaris 10. I use
the following configure command:
  $ ./configure  --with-ldap --enable-authnz-ldap --with-ldap-sdk=openldap


The configure goes fine, and the make goes fine for a while too, but dies
with the following error:
make[1]: Entering directory `/home/prepaid/httpd-2.2.0'
gcc -g -O2    -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT
-D_LARGEFILE64_SOURCE    -I/home/prepaid/httpd-2.2.0/srclib/pcre -I.
-I/home/prepaid/httpd-2.2.0/os/unix
-I/home/prepaid/httpd-2.2.0/server/mpm/prefork
-I/home/prepaid/httpd-2.2.0/modules/http
-I/home/prepaid/httpd-2.2.0/modules/filters
-I/home/prepaid/httpd-2.2.0/modules/proxy -I/home/prepaid/httpd-2.2.0/include
-I/home/prepaid/httpd-2.2.0/modules/generators
-I/home/prepaid/httpd-2.2.0/modules/mappers
-I/home/prepaid/httpd-2.2.0/modules/database
-I/home/prepaid/httpd-2.2.0/srclib/apr/include
-I/home/prepaid/httpd-2.2.0/srclib/apr-util/include -I/home/prepaid/httpd-
2.2.0/srclib/apr-util/xml/expat/lib
-I/home/prepaid/httpd-2.2.0/modules/proxy/../generators
-I/home/prepaid/httpd-2.2.0/modules/ssl
-I/home/prepaid/httpd-2.2.0/modules/dav/main
-c /home/prepaid/httpd-2.2.0/server/buildmark.c
/home/prepaid/httpd-2.2.0/srclib/apr/libtool --silent --mode=link gcc -g
-O2     -L/home/prepaid/httpd-2.2.0/srclib/apr-util/xml/expat/lib   -o
httpd  modules.lo buildmark.o -export-dynamic server/libmain.la
modules/aaa/libmod_authn_file.la modules/aaa/libmod_authn_default.la
modules/aaa/libmod_authz_host.la modules/aaa/libmod_authz_groupfile.la
modules/aaa/libmod_authz_user.la modules/aaa/libmod_authnz_ldap.la
modules/aaa/libmod_authz_default.la modules/aaa/libmod_auth_basic.la
modules/filters/libmod_include.la modules/filters/libmod_filter.la
modules/loggers/libmod_log_config.la modules/metadata/libmod_env.la
modules/metadata/libmod_setenvif.la modules/http/libmod_http.la
modules/http/libmod_mime.la modules/generators/libmod_status.la
modules/generators/libmod_autoindex.la modules/generators/libmod_asis.la
modules/generators/libmod_cgi.la modules/mappers/libmod_negotiation.la
modules/mappers/libmod_dir.la modules/mappers/libmod_actions.la
modules/mappers/libmod_userdir.la modules/mappers/libmod_alias.la
modules/mappers/libmod_so.la server/mpm/prefork/libprefork.la
os/unix/libos.la -lm /home/prepaid/httpd-2.2.0/srclib/pcre/libpcre.la
/home/prepaid/httpd-2.2.0/srclib/apr-util/libaprutil-1.la -lldap -ldl
-lpthread /home/prepaid/httpd-2.2.0/srclib/apr-util/xml/expat/lib/libexpat.la
/home/prepaid/httpd-2.2.0/srclib/apr/libapr-1.la -luuid -lsendfile -lrt
-lsocket -lnsl -lpthread
Undefined                       first referenced
 symbol                             in file
apr_ldap_info                       server/.libs/libmain.a(exports.o)
apr_ldap_init                       server/.libs/libmain.a(exports.o)
apr_ldap_url_parse_ext              server/.libs/libmain.a(exports.o)
apr_ldap_ssl_deinit                 server/.libs/libmain.a(exports.o)
apr_ldap_is_ldapi_url               server/.libs/libmain.a(exports.o)
apr_ldap_is_ldaps_url               server/.libs/libmain.a(exports.o)
apr_ldap_set_option                 server/.libs/libmain.a(exports.o)
apr_ldap_get_option                 server/.libs/libmain.a(exports.o)
apr_ldap_is_ldap_url                server/.libs/libmain.a(exports.o)
apr_ldap_ssl_init                   server/.libs/libmain.a(exports.o)
apr_ldap_url_parse                  server/.libs/libmain.a(exports.o)
ld: fatal: Symbol referencing errors. No output written to .libs/httpd
collect2: ld returned 1 exit status
make[1]: *** [httpd] Error 1
make[1]: Leaving directory `/home/prepaid/httpd-2.2.0'
make: *** [all-recursive] Error 1


I'm not sure how to proceed or what exactly is missing.


Thanks!

Mime
View raw message