httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark McCulligh <mmccu...@visualtech.ca>
Subject [users@httpd] SSL Logs and AWStats
Date Tue, 17 Jan 2006 16:59:12 GMT
Hi Group,

I have been looking at how to get AWStats to read SSL logs. And only 
finding other people looking for the same thing, but no real answers.

Below is how I have my VirtualHost setup.  Built using the examples in 
the docs
<VirtualHost 192.168.102.10:80>
    <...>
   ErrorLog      /usr/local/httpd/logs/site1/error_log
   CustomLog   /usr/local/httpd/logs/site1/access_log conbined
   LogLevel      emerg
</VirtualHost>
<VirtualHost 192.168.102.10:443>
    <...>
   ErrorLog      /usr/local/httpd/logs/site1/error_log
   TransferLog   /usr/local/httpd/logs/site1/access_log
   CustomLog  /usr/local/httpd/logs/site1/ssl_request_log \
       "%t %h %{SSL_PROTOCOL}x %{SLS_CIPHER}x \"%r\" %b"
</VirtualHost>

AWStats is reading the access_log file and of course when it read the 
records from SSL they come up as corrupted records. How do you get 
AWStats to read the SSL logs?

Thanks,
Mark.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message