httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bsd...@evolutiononline.com.au
Subject RE: [users@httpd] ProxyPass does not work withhostnamesonlyIP's.(mod_proxyApache 1.3)
Date Mon, 16 Jan 2006 14:17:23 GMT
Thanks for both your time and help!

Joshua you were right. I reloaded the server without chroot and it 
worked perfectly. Must be chroot blocking DNS resolution...

At least I know where the problem lies. Thanks!

Quoting Axel-St├ęphane  SMORGRAV <Axel-Stephane.SMORGRAV@europe.adp.com>:

> I think Joshua's advice was pretty sound. Somebody on an OpenBSD list 
> may have run into this problem previously, and he was certainly right 
> about the chroot stuff...
>
> Before closing the subject you could look into the /var/www/etc 
> directory and see if you find a resolv.conf file, and if not you 
> could perhaps add a definition of intranet.foo.org to the 
> /var/www/etc/hosts file to make sure the name is resolved correctly - 
> provided you have adequate permissions.
>
> -ascs
>
> -----Original Message-----
> From: bsdsec@evolutiononline.com.au [mailto:bsdsec@evolutiononline.com.au]
> Sent: Monday, January 16, 2006 3:05 PM
> To: users@httpd.apache.org
> Subject: RE: [users@httpd] ProxyPass does not work 
> withhostnamesonlyIP's.(mod_proxyApache 1.3)
>
> I cleared all my logs and restarted the server. Tried accessing the
> page twice with same error. It appears the requests never reach the
> backend server.
>
> Here are the full contents of my logs.
> ------------------------------------
> proxy: access_log
> ---
> talk.foo.org 10.5.5.50 - - [17/Jan/2006:00:25:00 +1030] "GET / 
> HTTP/1.1" 500 2
> 86 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8)
> Gecko/20051111 F
> irefox/1.5"
> talk.foo.org 10.5.5.50 - - [17/Jan/2006:00:25:50 +1030] "GET / 
> HTTP/1.1" 500 2
> 86 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8)
> Gecko/20051111 F
> irefox/1.5"
> ------------------------------------
> proxy: error_log
> ---
> [Tue Jan 17 00:24:45 2006] [notice] Initializing etag from
> /var/www/logs/etag-state
> [Tue Jan 17 00:24:45 2006] [notice] chrooted in /var/www
> [Tue Jan 17 00:24:45 2006] [notice] changed to uid 1001, gid 1001
> [Tue Jan 17 00:24:45 2006] [notice] Apache/1.3.29 (Unix) mod_ssl/2.8.16
> OpenSSL/
> 0.9.7g configured -- resuming normal operations
> [Tue Jan 17 00:24:45 2006] [info] Server built: unknown
> [Tue Jan 17 00:24:45 2006] [notice] Accept mutex: sysvsem (Default: sysvsem)
> [Tue Jan 17 00:25:00 2006] [debug] proxy_cache.c(0): No CacheRoot, so
> no caching
> . Declining.
> [Tue Jan 17 00:25:50 2006] [debug] proxy_cache.c(0): No CacheRoot, so
> no caching
> . Declining.
> ------------------------------------
> proxy: rewrite_log
> ---
> 10.5.5.50 - - [17/Jan/2006:00:25:00 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (2) init rewrite engine with requested uri /
> 10.5.5.50 - - [17/Jan/2006:00:25:00 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (3) applying pattern '^(/.*)$' to uri '/'
> 10.5.5.50 - - [17/Jan/2006:00:25:00 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (2) rewrite / -> http://internal.foo.org/
> 10.5.5.50 - - [17/Jan/2006:00:25:00 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (2) forcing proxy-throughput with http://internal.foo.org/
> 10.5.5.50 - - [17/Jan/2006:00:25:00 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (1) go-ahead with proxy request
> proxy:http://internal.foo.org/ [OK]
> 10.5.5.50 - - [17/Jan/2006:00:25:50 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (2) init rewrite engine with requested uri /
> 10.5.5.50 - - [17/Jan/2006:00:25:50 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (3) applying pattern '^(/.*)$' to uri '/'
> 10.5.5.50 - - [17/Jan/2006:00:25:50 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (2) rewrite / -> http://internal.foo.org/
> 10.5.5.50 - - [17/Jan/2006:00:25:50 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (2) forcing proxy-throughput with http://internal.foo.org/
> 10.5.5.50 - - [17/Jan/2006:00:25:50 +1030] 
> [talk.foo.org/sid#4eba0018][rid#4e3
> b4060/initial] (1) go-ahead with proxy request
> proxy:http://internal.foo.org/ [OK]
> ------------------------------------
> internal.foo.org: access_log
> ---
> ***EMPTY***
> ------------------------------------
> internal.foo.org: error_log
> ---
> [Tue Jan 17 00:24:51 2006] [notice] Initializing etag from
> /var/www/logs/etag-state
> [Tue Jan 17 00:24:51 2006] [notice] chrooted in /var/www
> [Tue Jan 17 00:24:51 2006] [notice] changed to uid 1009, gid 1009
> [Tue Jan 17 00:24:51 2006] [notice] Apache/1.3.29 (Unix) PHP/5.0.4
> mod_ssl/2.8.1
> 6 OpenSSL/0.9.7g configured -- resuming normal operations
> [Tue Jan 17 00:24:51 2006] [notice] Accept mutex: sysvsem (Default: sysvsem)
> ------------------------------------
>
> (Only changed actual domain with foo.org but everything else unchanged).
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message