httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Gordon <kevin.gor...@gmail.com>
Subject [users@httpd] ModAlias Problems
Date Fri, 23 Dec 2005 17:54:43 GMT
Hello!
 Happy holidays to everyone!

I am new to configuring apache. Previously I have always just used
pre-installed apache configurations, or modified only virtual host entries.
Recently I decided to play with Aliases

When I use Alias /something/ /path/to/actual/something/  the alias works, I
can see everything in the directory(But obviously cannot execute scipts)

When I use ScriptAlias /something/ /path/to/actual/something/  I get a 500
error on all my scripts.

in my apache config file I have


<IfModule mod_alias.c>
    ScriptAlias /cms/ "/home/cms/"
    <Directory "/home/cms/">
        AllowOverride None
        Options Indexes FollowSymLinks MultiViews ExecCGI
        Order allow,deny
        Allow from all
    </Directory>
</IfModule>

The permissions on the ~/cms/ directory is
Permissions    User       Group   Size    Date         Time  Directory
drwxrwxrwx  2 nobody  nogroup  4096 2005-12-23 10:50 cms

The Permissions of the content of the ~/cms/ directory is
Permissions  User   Group  Size    Date    Time Script
-rwxr-xr-x  1 nobody nogroup 69 2005-12-09 14:49 index1.cgi

How come my script is not accessable and only returns 500 errors?

The example is running at
http://blackbox.fidelitysoft.net/cms/

Can anyone provide me with any info on how to resolve this?


Thanks
Kevin

Mime
View raw message