httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Tozier <kentoz...@comcast.net>
Subject Re: [users@httpd] Problem setting up mod_alias for an external folder
Date Sun, 11 Dec 2005 21:19:02 GMT

On Dec 11, 2005, at 1:17 PM, Joshua Slive wrote:

> On 12/11/05, Ken Tozier <kentozier@comcast.net> wrote:
>
>> Then when I type 'localhost/images/' or '127.0.0.1/images/' into a
>> Safari or Firefox address bar, I get:
>> "Forbidden
>>
>> You don't have permission to access /images/ on this server.
>>
>> Apache/1.3.33 Server at mycomputer.local Port 80"
>>
>> Does anyone know whether Mac OS Tiger has some additional settings
>> somewhere that need to be changed to allow the above to work?
>
> Start here:
> http://httpd.apache.org/docs/1.3/misc/FAQ.html#forbidden

Well that works on my test machine. Unfortunately, in the actual  
application, what I need to do is point Apache to an existing  
directory on a production server which contains the images I need to  
use. Moving or copying the tens of thousands of images to the Web  
server isn't an option. Installing another copy of Apache on the  
production server isn't an option and opening up the permissions of  
the entire production server hierarchy to the world isn't an option.

Is there no way to target a specific folder without exposing the  
entire hierarchy it exists in? Could this be worked around with a  
custom module?

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message