httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Murach <ken_mur...@harvard.edu>
Subject Re: [users@httpd] apache 1.3.28 not starting up - no errors??
Date Fri, 16 Dec 2005 22:45:50 GMT
Thank you Christian for your help/information.

Actually come to find out, problem was with php module. PHP was being 
called from main config file and from users config file. Once I commented 
out users LoadModule php line from his config file, I was able to start up 
apache 1.3.28, but thanks again for the useful information. I will save 
your e-mail response for future references.

Best wishes and thanks again
Kenny

At 11:23 PM 12/16/2005 +0100, you wrote:
>Hi there,
>
>You can try to run it directly from the command line without the
>init-script. Just call the httpd directly. That way you see
>him exit.
>
>Then make sure you are looking into the right error.log.
>It does not need to be the one in your config file. Your httpd
>has a hardcoded error log, that is used until it can access the
>error.log defined in the config. Check the documentation
>of your distribution
>
>And finally you can start the command with "strace" or your
>local dialect's tool of choice. That way you will see the
>error killing your process.
>
>hope this helps,
>
>Christian
>
>
>On Tue, Dec 13, 2005 at 01:11:08PM -0500, Ken Murach wrote:
> > Hi everyone,
> >
> > I have a user who starts up apache 1.3.28 by running a script and giving
> > the script the argument of start
> >
> > This was working, but now the user is unable to get this to start up
> > anymore??
> >
> > Even as root, I am unable to start this up and there are no errors being
> > recorded in the error log file??
> >
> > Says apache is starting and pauses for a few seconds before returning me
> > back to a prompt but when I do a ps -ef | grep httpd | grep dev, it 
> doesn't
> > show up??
> >
> > Here is what I'm doing:
> >
> > itis-appdev # pwd
> > /etc/init.d
> >
> > itis-appdev # ./httpd-dev stop
> > kill: 17557: no such process
> >
> > itis-appdev # ./httpd-dev start
> > Starting the DEV instance of Apache web server
> >
> > itis-appdev # ps -ef|grep httpd | grep dev
> >     root 21398     1  0   Dec 02 ?        0:00
> > /usr/local/apache_wds_dev/bin/httpd -f
> > /www/dev/wdsphproot/apache-conf/httpd.co
> >   nobody 21403 21398  0   Dec 02 ?        3:28
> > /usr/local/apache_wds_dev/bin/httpd -f
> > /www/dev/wdsphproot/apache-conf/httpd.co
> >   nobody 21405 21398  0   Dec 02 ?        3:37
> > /usr/local/apache_wds_dev/bin/httpd -f
> > /www/dev/wdsphproot/apache-conf/httpd.co
> >   mladan 23178 23172  0   Dec 02 ?        0:01
> > /usr/local/apache_dev/bin/httpd -f
> > /usr/users/mladan/servers/stemcell/apache-co
> >   mladan 23172     1  0   Dec 02 ?        0:00
> > /usr/local/apache_dev/bin/httpd -f
> > /usr/users/mladan/servers/stemcell/apache-co
> >    vtole  3794     1  0   Nov 28 ?        0:00 /usr/local/apache/bin/httpd
> > -f /usr/users/vtole/servers/mydev/apache-conf/httpd
> >    vtole  3798  3794  0   Nov 28 ?        0:02 /usr/local/apache/bin/httpd
> > -f /usr/users/vtole/servers/mydev/apache-conf/httpd
> >   mladan 23173 23172  0   Dec 02 ?        0:01
> > /usr/local/apache_dev/bin/httpd -f
> > /usr/users/mladan/servers/stemcell/apache-co
> >    vtole  3795  3794  0   Nov 28 ?        0:02 /usr/local/apache/bin/httpd
> > -f /usr/users/vtole/servers/mydev/apache-conf/httpd
> >   mladan  5699     1  0   Nov 28 ?        0:00
> > /usr/local/apache_dev/bin/httpd -f
> > /usr/users/mladan/servers/harvie/apache-conf
> >   mladan  5700  5699  0   Nov 28 ?        0:01
> > /usr/local/apache_dev/bin/httpd -f
> > /usr/users/mladan/servers/harvie/apache-conf
> >   mladan  5759  5699  0   Nov 28 ?        0:01
> > /usr/local/apache_dev/bin/httpd -f
> > /usr/users/mladan/servers/harvie/apache-conf
> >
> >
> > Here is script that is used to start up this instance of apache:
> >
> > itis-appdev # cat httpd-dev
> > #!/usr/bin/bash
> > #
> > # Paul Lembo March 2003
> > # Start up the Apache DEV web server
> >
> > case "$1" in
> > 'start')
> > 
> LD_LIBRARY_PATH=/lib:/usr/lib:/usr/local/lib:/usr/local/include:/usr/local/ssl/include:/usr/local/ssl/lib
> >         export LD_LIBRARY_PATH
> >         if [ -x /usr/local/apache_dev/bin/httpd -a -f
> > /www/dev/conf/httpd.conf ]; then
> >                 echo "Starting the DEV instance of Apache web server"
> >                 /usr/local/apache_dev/bin/httpd -f /www/dev/conf/httpd.conf
> >         fi
> >         ;;
> >
> > 'stop')
> >         pid=`cat /www/dev/logs/httpd.pid`
> >         if [ X = "$pid"X ]; then
> >                 echo "WARNING:  Cannot open pid file, trying ps output"
> >                 pid=`/usr/bin/ps -fu root | grep -v grep | grep apache_dev
> > | grep httpd | awk ' { print $2 } ' `
> >         fi
> >         if [ X = "$pid"X ]; then
> >                 echo "HTTPD is not running"
> >         else
> >                 /usr/bin/kill $pid
> >         fi
> >         ;;
> > 'restart')
> >         pid=`/usr/bin/ps -fu root | grep -v grep | grep apache_dev | grep
> > httpd | awk ' { print $2 } ' `
> >         if [ X = "$pid"X ]; then
> >                 echo "HTTPD is not running"
> >         else
> >                 /usr/bin/kill -1 $pid
> >         fi
> >         ;;
> >
> > *)
> >         echo "Usage: $0 { start | stop | restart }"
> >         exit 1
> >         ;;
> > esac
> > exit 0
> >
> > Any ideas as to why it says its starting but doesn't and doesn't record 
> any
> > errors in the error_log file??
> >
> > Any help is greatly appreciated.
> > Thank you
> > Kenny
> >
> >
> >
> > ---------------------------------------------------------------------
> > The official User-To-User support forum of the Apache HTTP Server Project.
> > See <URL:http://httpd.apache.org/userslist.html> for more info.
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> >   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
>
>--
>Christian Folini - <christian.folini@netnea.com>
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message